Another 'cannot get smtp working' thread

I’ve been struggling to make outgoing emails work for a full day yesterday. When I try to send a test email, there is a popup message ‘There was a problem sending test email’ but I cannot find neither cause of it, nor any trace of errors in log files.

I checked multiple times for typos in app.yml, all settings seem to be right;
I can successfully connect to the smtp server ( from both the host and from within the container. So there is no network issue,

rails/production.log doesn’t contain any errors, and of course, nothing reaches the mail server so there is nothing in those logs either…

I tried multiple combinations of options, turning on and off smtp_openssl_ferify_mode, switching authentication from plain to login, so far no luck…

Is there any other place I should look for the explanation?


See here to start:

1 Like

Thanks Daniela,

I’m sorry, I should’ve clarified what I meant by ‘been struggling all day’ - I’ve reviewed all the instructions, as well as questions, blogs on stackoverflow or others - none of the already described issues (and solutions) seem to be covering my case, thus the new topic.

From the Troubleshooting email:

Did you enter email settings correctly?


Are your SMTP connections being blocked?


What do the Discourse logs say?


What do your email provider logs say?

nothing, requests don’t reach there

Did you properly set up DKIM and SPF records for your domain?

see above;

Is the email domain correct?

yes, I’m also explicitly providing smtp_domain parameter

Are you using an IP address as the mail domain?


Email still doesn’t work! What next?

yes. What can I do next?

I suggest switching to a “real” outgoing mail provider like mailgun, even as an experiment, to see if you get different results.


Thank you Jeff,

Unfortunately, they need the CC info even for the free plan and I can’t sign up for their service just to test what’s wrong with my discourse installation… I’ll definitely need to read more about ‘real’ vs ‘nonreal’ mail services out there,

But would love to know what’s the status of the email feature in discourse - it is only guarantied to work with mailgun and no other channels are supported - then I’m just wasting my time, or, it should work with any smtp service and something must be wrong with MY setup?

I was operating under the assumption that both discourse and work just fine and I’m only having issues because I made a mistake somewhere - and was trying to get some tips to diagnose my specific issue, i.e. application does show a popup message saying email was not sent,

So perhaps there is a place to see more detailed stack trace for this popup?

Dear Vavalomi,

You can use elastic email for transaction email instead of zoho.

I have also face same issue with zoho. I hope elastic email help you to resolve your email query.

Just in case someone gets to this topic, at the end, I managed to make it work, it was of course the setup mistake but one that doens’t show up in any logs …

While I was trying to find errors in app.yml and smtp settings etc, the the problem was the notification parameter in admin settings - it was @forum.mydomain instead of @mydomain

Simple fix and email works just fine with ‘nonreal’ service like Zoho…