# Noch ein: Upgrade fehlgeschlagen von 3.1.0 auf 3.2.0 beta 4

**URL:** <https://meta.discourse.org/t/another-failed-upgrade-from-3-1-0-to-3-2-0-beta-4/290191>\
**Category:** Self-hosting\
**Created:** [1. Januar 2024 um 15:05 UTC](https://meta.discourse.org/t/another-failed-upgrade-from-3-1-0-to-3-2-0-beta-4/290191 "2024-01-01T15:05:40Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![Firepup650](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/firepup650/32/465200_2.png) [@Firepup650](https://meta.discourse.org/u/Firepup650)\
**Post date:** [1. Januar 2024 um 16:35 UTC](https://meta.discourse.org/t/another-failed-upgrade-from-3-1-0-to-3-2-0-beta-4/290191/2 "2024-01-01T16:35:12Z")

</div>

> [@jhf2442](#):
>
> Ich habe auch diese hier in den Logs gefunden – es ist `git clone [GitHub - mozilla/discourse-email-all: Allow an admin to email everybody](https://github.com/mozilla/discourse-email-all.git)`, den ich zur Sicherheit vorerst deaktiviert habe
> 
> ```plaintext
> ==> unicorn.stderr.log <==
> I, [2024-01-01T15:00:30.194986 #85] INFO -- : Refreshing Gem list
> Plugin name is 'email-all', but plugin directory is named 'discourse-email-all'
> 
> ```

Das sollte in Ordnung sein, wenn ich mich recht erinnere, gibt das offizielle #topic-voting Plugin die gleiche Art von Warnung aus.

> [@jhf2442](#):
>
> ```plaintext
> warning " > discourse-markdown-it@1.0.0" has unmet peer dependency "xss@*".
> warning "workspace-aggregator-36c917e1-4a06-4dbb-be15-7fedd9ba3d70 > discourse > @ember/legacy-built-in-components@0.5.0" has incorrect peer dependency "ember-source@>= 4.8".
> warning "workspace-aggregator-36c917e1-4a06-4dbb-be15-7fedd9ba3d70 > discourse > @uppy/aws-s3@3.0.6" has incorrect peer dependency "@uppy/core@^3.1.2".
> warning "workspace-aggregator-36c917e1-4a06-4dbb-be15-7fedd9ba3d70 > discourse > @uppy/aws-s3-multipart@3.1.3" has incorrect peer dependency "@uppy/core@^3.1.2".
> warning "workspace-aggregator-36c917e1-4a06-4dbb-be15-7fedd9ba3d70 > discourse > @uppy/xhr-upload@3.1.1" has incorrect peer dependency "@uppy/core@^3.1.2".
> warning "workspace-aggregator-36c917e1-4a06-4dbb-be15-7fedd9ba3d70 > discourse-plugins > ember-this-fallback@0.4.0" has unmet peer dependency "ember-source@^3.28.11 || ^4.0.0".
> warning "workspace-aggregator-36c917e1-4a06-4dbb-be15-7fedd9ba3d70 > discourse > @uppy/aws-s3 > @uppy/xhr-upload@3.3.0" has incorrect peer dependency "@uppy/core@^3.2.1".
> 
> ```

Das sind auch normal, wir haben bei jedem Rebuild die gleichen Warnungen und es ist in Ordnung.

---

_[View the full topic](https://meta.discourse.org/t/another-failed-upgrade-from-3-1-0-to-3-2-0-beta-4/290191)._
