Any way to disable gzip of backup?

My discourse instance is hosted at DigitalOcean on a droplet with 60GB SSD.

Out of 60 GB, 34 GB is already consumed, so free space left is 25GB.

My backup settings

  1. Keeps just latest 1 backup
  2. And sends the same to Amazon S3

What is the exact issue I’m facing

  1. Backup starts.
  2. It creates the archive. The archive size = 14 GB. Free space left = 11GB.
  3. It then starts to do create a gzip of the archive.
    (once gzip is successfully done, the archive will be deleted, and only the gzipped version will stay)
  4. Unfortunately, the gzip process fails, because of low free space.
  5. Because of this the backup is NOT sent to Amazon S3.

I have 2 questions

  1. Is it possible to disable gzip of backup?
  2. If gzip of backup fails - can it be made to send the archive to Amazon S3? That way, at least something is being sent to the cloud.

I strongly suggest turning on database-only backup, then you can backup uploads yourself. That will save a ton of space.

We already made a pass at optimizing this, right now there’s nothing more to do – if you are low on space you must backup database only.

1 Like

Could you please tell me more about that. How can it be done?

Copy the uploaded files to some other location, using standard Unix copy commands.

1 Like

Is this the directory



That’s the one. Just rsync it somewhere else. I offer that as a service, but I’m pretty sure you don’t need my help.

You might also get the containers directory and then you’ll have enough to do a rebuild

1 Like

Yes, I thought about that, but then, if in case I plan to do a restore at a later stage, restoring won’t be a 1 step process - right?

Say, I take backup of uploads separately and DB separately.

How is the restore process done in this case? (I have done restore using complete backup, but I haven’t done restore using DB+uploads separately)

Just rsync that uploads directory and then restore the database (after you rebuild the container).


Good idea. Got it.

I’m going to change my backup settings from full backup to just DB backup.