Anyone tried an SSO with Salesforce yet?


(Scott Trager) #1

Has anyone tried an SSO with Salesforce yet? How did it go?


(Justin Smits) #2

Have you had any updates on this?


(Scott Trager) #3

Nope - looks like it hasn’t been done yet, although we are looking to give it a “go” in the near future if everything turns out the way I hope…


(Justin Smits) #4

any luck with this one?


(Scott Trager) #5

We hired the Discourse team to help us here, but the SSO actually works really well so far.


(Frans Thamura) #6

I love to know, how Discourse can work with any OAuth2 Server, (is SF also Oauth2)

I think the SSO work well, even in my case, still have several issue that i am working to troubleshoot it.

F


(Roarke Lynch) #7

I haven’t had luck.

I pulled down and configured the [Discourse Salesforce Auth] (GitHub - discourse/discourse-salesforce-auth) plugin to a test instance of mine. Clicking the “Sign in with Salesforce” button on the login dialog gives me a 500.

Error logs say:

URI::BadURIError (both URI are relative)
/usr/local/lib/ruby/2.0.0/uri/generic.rb:1203:in `rescue in merge’

Backtrace:

/usr/local/lib/ruby/2.0.0/uri/generic.rb:1203:in rescue in merge' /usr/local/lib/ruby/2.0.0/uri/generic.rb:1200:inmerge’
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/faraday-0.9.1/lib/faraday/connection.rb:406:in build_exclusive_url' /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/faraday-0.9.1/lib/faraday/connection.rb:348:inbuild_url’
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/oauth2-1.0.0/lib/oauth2/client.rb:66:in authorize_url' /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/oauth2-1.0.0/lib/oauth2/strategy/auth_code.rb:18:inauthorize_url’
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/omniauth-oauth2-1.3.1/lib/omniauth/strategies/oauth2.rb:52:in request_phase' /var/www/discourse/plugins/discourse-salesforce-auth/plugin.rb:63:inrequest_phase’


(Scott Trager) #8

The plugin was made by @sam so he’d be the best one to help you here. Did you configure everything on the salesforce side?


(Roarke Lynch) #9

I don’t think the plugin is even getting to the point that it can contact SF. I saw the new general OAuth support plugin and was going to give that a try also.


(Mark Robustelli) #10

Has anyone tinkered with this recently? It is something we are looking at. May even be willing to pay someone to set it up. @sam ? If anyone is interested, please just let me know.


(Sam Saffron) #11

Our SSO plugin for salesforce works fine and is in production at https://community.wd.com/

The plugin requires url, client id and secret via site settings

Trouble with salesforce is that it is a royal nightmare multiplied by nightmare to get it all working, it took us weeks of back and forth with salesforce experts to get it all configured right for western digital.