App doesn't load on iphone safari


(Pad Pors) #1

our forrum doesn’t load in safari, iphone. while I can easily connect to meta.discourse.com.

error: safari couldn't open the page because the page stopped responding.

the site doesn’t load in safe mode as well.

any idea would be appreciated.

I tried to check cloudflare options, but deactivating none, has helped.

so far I tested it on 3 different iphone devices, and all responded the same.


(Sam Saffron) #2

Works for me on my iPhone X


(Jeff Atwood) #3

In my experience this usually means your HTTPS configuration is busted somehow.

However if Sam can’t repro on his iPhone then it is something upstream of you (but not Sam) that is interfering.


(Pad Pors) #4

doesn’t it take a very long time (unusual) to load the site?

also may this be related to our web connection? as I tried it on different iphones, and the result was the same.


(Sam Saffron) #5

not sure, I think a good thing to try first is a very very limited test… see if something super simple like:

https://padpors.com/user_avatar/padpors.com/pd.in/50/4089_1.png works.

Also… Cloud Flare … try disabling that


#6

Works for me (iPhone 7, albeit iOS 12 PB)


(Pad Pors) #7

thanks for the confirmation.

also our analytics shows that we have good amount of users connected in Safari as well as iPhone. which can be a good sign.

meanwhile the avatar link wasn’t loaded using 2 different iPhone devices in our test.

not sure what we should look for, now!


(Pad Pors) #8

it seems that users of iphone, using Safari and Firefox, can only open our site using a VPN, while they can easily open it in Chrome, without a VPN.

@sam may you have any idea why such thing has happened?

p.s.: we disabled Cloud Flare, but it didn’t help either. Also, other OS has no problem connecting the site without VPN.


(Sam Saffron) #9

Hmm, when they are connected to the internet via wifi does it work? What about other devices connected to the same wifi?


(Pad Pors) #10

other devices, e.g. a Laptop, connecting to the same wifi connection can easily open the site.

also using a wifi doen’t solve the problem, i.e. the site still needs a vpn to launch in ios.


(Kane York) #11

What happens when someone in a different country tries to load it on their iphone?


(Sam Saffron) #12

I works… I don’t know but maybe the telco has some special network config provided by the network.

I would try … moving to airplane mode, resetting all network settings, connecting to wifi and seeing if this break your site policy is a gift from your telco.


(Pad Pors) #13

I looked around and find some similar issues but for different websites here:

their problem has been fixed by enabling dns caching in the router.

I couldn’t solve the problem in our case though, since the problem persists regardless of the router (even when using mobile data). Resetting all the network setting doesn’t solve it either.


I can see this is something related to hardware rather than the software. and I should (and would) look for the solution out of meta-discourse.

meanwhile since the community level of knowledge here is high, I’d appreciate if anyone knows what I should look for.