Apple touch icon doesn't show if there is no sub domain


(sipp11) #1

I couldn’t find any related topic about this, but when I tried with my install. I’ve found that I only get add to home screen icon on my iPad when I use any URL with sub domain, ie. www.example.com, x1.example.com. However, if I use example.com as URL, I will not get the icon at all.

First I thought it was my own issue, URL redirect thing, but as far as I’ve tried, it’s not.

note: my apple_touch_icon_url is on S3.


(Jeff Atwood) #2

I am seeing very weird behavior from my iPad when adding to favorites or home screen. I know we recently fixed a typo bug in the apple-touch-icon meta tag, too.

Aha, well this explains it…

<link rel="apple-touch-icon" type="image/png" href="/images/default-apple-touch-icon.png">

https://meta.discourse.org/images/default-apple-touch-icon.png

That’s the dev instance icon, not the one for meta. @zogstrip can we get the right assets here?


(Régis Hanol) #3

@sipp11 are you still experiencing this issue?

@codinghorror I just updated the apple-touch-icon on meta with the right logo :wink:


(Jeff Atwood) #4

Is the touch icon correct for try.discourse.org as well?


(sipp11) #5

Nope, as of 0.9.7.9, the icon is there w/o any issue. :slight_smile:


(Régis Hanol) #6

Should be working now on try too.


(Jeff Atwood) #7