Application doesn't update when enabling/disabling/modifying color theme


(Franz) #1

When I enable, disable or modify a color theme (in Admin -> Customize -> Colors) in the Discourse instance I’m administrating, the changes are no longer applied. I made sure it isn’t a cache issue on the client side. I suppose restarting the application would work but obviously this isn’t a satisfactory solution.

I’m running Discourse 1.2.0 beta 2.


(Régis Hanol) #2

What are you trying to do? Disable the custom colors?


(Franz) #3

I’m trying to tweak the colors. It has no immediate effect. I then tried to disable the color theme entirely, still no effect.


(Franz) #4

(I believe this is a regression introduced between 1.0.0 and 1.2.0 beta 2.)


#5

Actually experienced the same issue while tweaking some colors a few days ago. Was fine on 1.X when I first used discourse I think.

The color scheme got applied almost instantly, now you have to rebuild discourse via ssh all the time.

Custom CSS/HTML still works fine.

cc @zogstrip


(Régis Hanol) #6

I believe @sam pushed a fix already

https://github.com/discourse/discourse/commit/4a7e0416d118b49ca7d48d51238cdcc97152eade


(Franz) #7

Awesome, thanks all for the excellent support (as always).


#8

Thanks, that resolved the issue!


(Régis Hanol) #9