Approve post gives Internal Server Error

System flagged a post because the user typed too fast, I wanted to approve it, but it gives me an internal server error. I am on the latest: 2.4.0.beta7

Error log says:

Error: Internal Server Error
Url: https://forum.e-liquid-recipes.com/assets/ember_jquery-0e61869941dc064cb49a851e9d61116c10b0bca252f03f2af0d7b8afd2528392.js
Line: 9
Column: 9188
Window Location: https://forum.e-liquid-recipes.com/review

Can you have a look in forum.e-liquid-recipes.com/logs is there a backtrace and error for the server part.

The client error is not giving much info here.

1 Like

Yeah this is not going to help… there is a server error … one without .js

To me it looked like that was the only one that appeared when I tried to approve. I just cleared logs and went to approve it again and the post was gone?! I don’t immediately see it on the site, so maybe he deleted it?

I just tried to search for the user to see his activity:

image

Clicking him gives me a 404 (same error I’ve encountered on a few users) - I seem to remember an error in the logs about duplicate ActiveRecord for that username?

I just heard from one of my moderators - he was confused and tried to delete the post and then delete the user, hoping he’d be recreated (I use SSO) - it deleted two users with similar/same usernames he said…

Could it be a bug with the user creation over SSO? Case sensitivity or something?