Apt-get autoclean command doesn't work on Mac


(Hidetaka Ko) #1
sudo apt-get autoclean
sudo apt-get autoremove

When I tried to use this command, I encountered this error.

apt-get: command not found

What command should I use for this?


(Matt Palmer) #2

You should use apt-get autoclean. That it isn’t working suggests you aren’t using an Ubuntu machine.


(Hidetaka Ko) #3

I’m using Mac OS. What command should I use instead of apt-get?


(Matt Palmer) #4

What does this have to do with Discourse?


(Hidetaka Ko) #5

Yes. To rebuild discourse app, I tried to use these command like below.

sudo ./launcher rebuild  app
sudo ./launcher cleanup

But, I encountered these errors.
./launcher: line 96: cannot create temp file for here-document: No space left on device


(Jeff Atwood) #6

You need to stick to this topic, before opening new support topics. You’re on a Mac but you aren’t telling people that.


(Robby O'Connor) #7

(Hidetaka Ko) #8

I have storeage on Mac. But, I don’t have storeage on docker and discouse.


(Robby O'Connor) #9

How are you using docker? Docker Machine + Virtualbox? Docker for mac?


(Hidetaka Ko) #10

I’m using Docker for Mac.


(Robby O'Connor) #11

Try: docker system prune


(Robby O'Connor) #12

Also check out the faqs on Docker for mac: Frequently asked questions (FAQ) | Docker Documentation

It tells you how to fix this.


(Hidetaka Ko) #13

I tried like below.

but, I still encounter this error.


(Matt Palmer) #14

You do realise that an EC2 instance is not the same thing as your local Mac, right?


(Hidetaka Ko) #15

Yes. You are right. What should I do on EC2?


(Matt Palmer) #16
  1. Use Ubuntu 16.04, not whatever RHEL-derived AMI you’re using (assumption based on the prompt), because Amazon Linux is nasty, and all our experience and documentation is based on Ubuntu.
  2. Follow the available documentation.