# Arch Linux - service-start-limit-hit

**URL:** https://meta.discourse.org/t/arch-linux-service-start-limit-hit/111438
**Category:** Self-hosting
**Created:** [2019年三月13日 02:28 UTC](https://meta.discourse.org/t/arch-linux-service-start-limit-hit/111438 "2019-03-13T02:28:03Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![SealsRock12](https://avatars.discourse-cdn.com/v4/letter/s/b5ac83/32.png) [@SealsRock12](https://meta.discourse.org/u/SealsRock12)
#### Post date: [2019年三月13日 02:28 UTC](https://meta.discourse.org/t/arch-linux-service-start-limit-hit/111438/1 "2019-03-13T02:28:03Z")

</div>

Hello Everyone,  
I am trying to install discourse on the computer I am typing this on, which is currently running Arch Linux. I followed the instructions and just ran `./discourse-setup`. I set up all the necessary features, output:

```plaintext
# ./discourse-setup
which: no docker.io in (/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/var/lib/flatpak/exports/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl:/var/lib/snapd/snap/bin)
which: no docker.io in (/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/var/lib/flatpak/exports/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl:/var/lib/snapd/snap/bin)
The configuration file containers/app.yml already exists!

. . . reconfiguring . . .

Saving old file as app.yml.2019-03-12-191642.bak
Stopping existing container in 5 seconds or Control-C to cancel.
which: no docker.io in (/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/var/lib/flatpak/exports/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl:/var/lib/snapd/snap/bin)
Device "docker0" does not exist.
Cannot connect to the docker daemon - verify it is running and you have access

Found 8GB of memory and 2 physical CPU cores
setting db_shared_buffers = 2048MB
setting UNICORN_WORKERS = 4
containers/app.yml memory parameters updated.

Hostname for your Discourse? [<I am not showing you for privacy>]: 
Email address for admin account(s)? [<I am not showing you for privacy>]: 
SMTP server address? [<I am not showing you for privacy>]: 
SMTP port? [587]: 
SMTP user name? [<I am not showing you for privacy>]: 
SMTP password? [<I am not showing you for privacy>]: 
Optional email address for setting up Let's Encrypt? (ENTER to skip) [me@example.com]: 

Does this look right?

Hostname : <I am not showing you for privacy>
Email : <I am not showing you for privacy>
SMTP address : <I am not showing you for privacy>
SMTP port : 587
SMTP username : <I am not showing you for privacy>
SMTP password : <I am not showing you for privacy>

ENTER to continue, 'n' to try again, Ctrl+C to exit: 

Configuration file at updated successfully!

Updates successful. Rebuilding in 5 seconds.
Building app
which: no docker.io in (/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/var/lib/flatpak/exports/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl:/var/lib/snapd/snap/bin)
Device "docker0" does not exist.

```

I ran `systemctl status docker`, and this was the output:

```plaintext
# systemctl status docker
● docker.service - Docker Application Container Engine
   Loaded: loaded (/usr/lib/systemd/system/docker.service; disabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Tue 2019-03-12 19:09:43 PDT; 11min ago
     Docs: https://docs.docker.com
  Process: 6070 ExecStart=/usr/bin/dockerd -H fd:// (code=exited, status=1/FAILURE)
 Main PID: 6070 (code=exited, status=1/FAILURE)

Mar 12 19:09:43 <hostname> systemd[1]: docker.service: Service RestartSec=100ms expired, scheduling restart.
Mar 12 19:09:43 <hostname> systemd[1]: docker.service: Scheduled restart job, restart counter is at 3.
Mar 12 19:09:43 <hostname> systemd[1]: Stopped Docker Application Container Engine.
Mar 12 19:09:43 <hostname> systemd[1]: docker.service: Start request repeated too quickly.
Mar 12 19:09:43 <hostname> systemd[1]: docker.service: Failed with result 'exit-code'.
Mar 12 19:09:43 <hostname> systemd[1]: Failed to start Docker Application Container Engine.

```

Here is the snippet of `journalctl -xe`:

```plaintext
-- Subject: A stop job for unit docker.socket has begun execution
-- Defined-By: systemd
-- Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- A stop job for unit docker.socket has begun execution.
-- 
-- The job identifier is 6080.
Mar 12 19:09:43 <hostname> systemd[1]: Starting Docker Socket for the API.
-- Subject: A start job for unit docker.socket has begun execution
-- Defined-By: systemd
-- Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- A start job for unit docker.socket has begun execution.
-- 
-- The job identifier is 6080.
Mar 12 19:09:43 <hostname> systemd[1]: Listening on Docker Socket for the API.
-- Subject: A start job for unit docker.socket has finished successfully
-- Defined-By: systemd
-- Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- A start job for unit docker.socket has finished successfully.
-- 
-- The job identifier is 6080.
Mar 12 19:09:43 <hostname> systemd[1]: docker.service: Start request repeated too quickly.
Mar 12 19:09:43 <hostname> systemd[1]: docker.service: Failed with result 'exit-code'.
-- Subject: Unit failed
-- Defined-By: systemd
-- Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- The unit docker.service has entered the 'failed' state with result 'exit-code'.
Mar 12 19:09:43 <hostname> systemd[1]: Failed to start Docker Application Container Engine.
-- Subject: A start job for unit docker.service has failed
-- Defined-By: systemd
-- Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- A start job for unit docker.service has finished with a failure.
-- 
-- The job identifier is 6011 and the job result is failed.
Mar 12 19:09:43 <hostname> systemd[1]: docker.socket: Failed with result 'service-start-limit-hit'.
-- Subject: Unit failed
-- Defined-By: systemd
-- Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- The unit docker.socket has entered the 'failed' state with result 'service-start-limit-hit'.

```

Please assist me. I also changed my `app.yml` port to 1209.

---

<div class="post-metadata">

### Author: ![sam](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sam/32/102149_2.png) [@sam](https://meta.discourse.org/u/sam)
#### Post date: [2019年三月13日 03:13 UTC](https://meta.discourse.org/t/arch-linux-service-start-limit-hit/111438/2 "2019-03-13T03:13:55Z")

</div>

Looks to me like docker is refusing to start on your system, I would recommend starting by figuring out how to get docker working

---

<div class="post-metadata">

### Author: ![SealsRock12](https://avatars.discourse-cdn.com/v4/letter/s/b5ac83/32.png) [@SealsRock12](https://meta.discourse.org/u/SealsRock12)
#### Post date: [2019年三月13日 03:54 UTC](https://meta.discourse.org/t/arch-linux-service-start-limit-hit/111438/3 "2019-03-13T03:54:06Z")

</div>

May you help me with that, or do I need to ask somewhere else?

---

<div class="post-metadata">

### Author: ![sam](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sam/32/102149_2.png) [@sam](https://meta.discourse.org/u/sam)
#### Post date: [2019年三月13日 04:04 UTC](https://meta.discourse.org/t/arch-linux-service-start-limit-hit/111438/4 "2019-03-13T04:04:29Z")

</div>

Probably best ask on docker forums or arch linux forums

---

<div class="post-metadata">

### Author: ![SealsRock12](https://avatars.discourse-cdn.com/v4/letter/s/b5ac83/32.png) [@SealsRock12](https://meta.discourse.org/u/SealsRock12)
#### Post date: [2019年三月16日 01:49 UTC](https://meta.discourse.org/t/arch-linux-service-start-limit-hit/111438/5 "2019-03-16T01:49:20Z")

</div>

Restart your computer 😉

---

<div class="post-metadata">

### Author: ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)
#### Post date: [2019年四月15日 01:49 UTC](https://meta.discourse.org/t/arch-linux-service-start-limit-hit/111438/6 "2019-04-15T01:49:35Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
