[ARCHIVE] Topic List Previews

(Angus McLeod) #934

@nothing As suggested, let me know what happens when you’ve tried rebuilding the html on an affected post. You can hide the suggested topics header using a CSS site customisation.

(Keith) #935

Apologies for the repeat question (I know this was explained somewhere, but I can’t find it) How do I regenerate the thumbnails on all old posts? I’ve had quite a few topics lose their thumbnails, especially after just running this most recent update. I know that if I admin/edit the topic, let the thumbnail generate, then press save (and reset bump date), it will generate the thumbnail again, but I’d rather not do this by hand on every topic.

If I recall correctly, there is a way to rebake posts and generate the thumbs as a batch?

(Hakan) #936

I did not understand what you mean.

The pictures in the topic are not visible in the topic list thumb.

I did launcher rebuild app. What else do I have to do if you tell me in a descriptive way?

(Vincent) #937

You rebuilt your Discourse container, which contains none of your forum’s data. You need to enter your container and use rake to rebake posts:

./launcher enter app
rake posts:rebake

If you want to rebuild a specific post, I think the easiest way is to use the advanced setting “Rebuild HTML” (located in the footer of the post, behind the three-dots button).


Thanks once again… as for d topic excerpt length for mobile setting, i thought it wud b nice to have dat as too much character may look great on desktop but clumsy on mobile and vice versa.
Anyways great job… I mean it… your plugin has given my forum https://www.clarify.ng an amazing look.

(Hakan) #939

Hello. I tried, but there was no change :frowning: @angus


@angus hello, I just update my discourse instance to the latest and discovered d topic-actions (likes and bookmarks) has disappeared.

Checked d settings in admin and discovered some settings check-boxes are missing.

I think d bug is with d discourse update as some other setting outside TLP have missing checkboxes too.

(Tom Ruh) #941

Can you help me understand where the setting has moved to or how it has changed?

Thank you for all the hard work and great contributions.


@angus Is there any chance you could make your plugin work with search results?

(Angus McLeod) #943

@googleboy I just updated (v2.1.0.beta4 +155) and I’m still seeing the topic-actions on my sandbox, e.g. social - Angus’ Sandbox. Try toggling the action setting?

I’m also not seeing any issue with the settings?

@SpaceMonkey It’s the same as before



@ChameleonScales Possibly, I’ll have to take a closer look later in the week.

(Hakan) #944

Did you look at my problem friend ? @angus

(Tom Ruh) #945

@angus thank you for you response. My problem must be have a different source. My images are not full sizing with and auto height, even though I am using the setting.

(Angus McLeod) #946

@SpaceMonkey Width and height is always controlled by the thumbnail width and height settings, regardless of the ‘display’ settings used. So change the site wide or category-specific width and height and rebake the relevant posts.

@nothing Your issue is that Discourse is not processing any of the images that appear in your posts. If the image is not processed TLP cannot create a thumbnail. All of the images in posts on your forum have urls that look like this:


Images processed by discourse have urls that look like this

[protocol][image domain]/optimized/3X/c/6/c69a7218ce9a11e72096955c7a6df1b42103864c_1_690x227.png

So, one of your multiple modifications is interfering with the normal Discourse treatment of images.

Try turning off all your other modifications, leave TLP on, create a new post and see if it creates a thumbnail. Then add all your other modifications back one by one doing the same thing, until it stops working.

(Hakan) #947

I keep pictures on a different server.
Is there no solution for that? I use pictures on CDN.
I do not want to upload them to my site because too many images have been uploaded to my site.

(Angus McLeod) #948

Well, first you need to establish that your CDN is the issue. Try changing the settings and see if it has any affect.

(Hakan) #949

I’ve been using it this way since I opened the site, so I upload pictures to another server. But after the last update on your plugin, this problem started to happen.

And im try download remote images setting ON and rake “post: rebake” but not change thumb.

Could you make an update for images added from far away for pictures added from outside the subject? Because I do not want to upload pictures on any topic. All images are added from other sites imgur, cdn vs.vs

(Angus McLeod) #950

Great, the screenshot of you logs clearly identifies the problem. Next time, take a look at your logs straight away and send me a clear screenshot like that.

The cooked_post_processor can’t determine the height and width of the images on your site for some reason.

I’ve added a check for this case. Update and see if that fixes the exception in your logs. It may not fix the issue itself, but let’s see what happens with just this first.

(Hakan) #951

ı did .launcher rebuild app and post:rebake Now I expect to add new content.

(Sora &\) #952

Can we enable thumbail preview for only topic not all topic of category?

(Le Chi Cong) #953

Hi guys. I’m learning the discourse and my project is having a bug that I tried to milk but not yet successful. I have edited the files. Please help me. it follows.