# ArgumentError: diretório para pid=/.../unicorn.pid não gravável

**URL:** https://meta.discourse.org/t/argumenterror-directory-for-pid-unicorn-pid-not-writable/274948
**Category:** Self-hosting
**Created:** [Agosto 13, 2023, 1:53pm UTC](https://meta.discourse.org/t/argumenterror-directory-for-pid-unicorn-pid-not-writable/274948 "2023-08-13T13:53:52Z")
**Posts on this page:** 1
**Showing post:** 24

<div class="post-metadata">

### Author: ![Falco](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/falco/32/179432_2.png) [@Falco](https://meta.discourse.org/u/Falco)
#### Post date: [Agosto 22, 2023, 6:16pm UTC](https://meta.discourse.org/t/argumenterror-directory-for-pid-unicorn-pid-not-writable/274948/24 "2023-08-22T18:16:14Z")

</div>

> [@DarthLasciel](#):
>
> Não fiz nada além de instalar o nginx

Espere, por que você instalou o nginx? A instalação padrão falhará se já houver algo no host usando a porta 80.

Em um novo droplet da Digital Ocean, não fiz nada que não estivesse no guia de instalação oficial, e funcionou bem. Deixei o instalador do Discourse instalar o docker para mim e tudo mais.

Tentar reproduzir isso está se mostrando complicado.

---

_[View the full topic](https://meta.discourse.org/t/argumenterror-directory-for-pid-unicorn-pid-not-writable/274948)._
