Autocomplete broken for @mentions and Emoji on Linux Chrome


(Arpit Jalan) #1

In my previous post I tried to mention @sam, but the autocomplete list disappeared as soon as I pressed “s”. I tried doing the same for @codinghorror but the same thing happens, the list disappears as soon as I press “c”. I am pretty sure this was working few days back.

Also when I try to browse the initial list (which appears when I type “@”), the list disappears as soon as I press up and down key.

I tried doing same on try.discourse.org, I am getting same behavior there also.


Emoji not working in composer
(Sander Datema) #2

Was this on Meta and on what browser? Can’t repro this…


(Kane York) #3

I’m seeing it broken here on meta too - no completions for @Sand unless I backspace, in which case the completions pop up.


(Arpit Jalan) #4

Ok, so I tried this on Meta, on two different machines:

  1. On Mac, it works fine on all browsers (tested on Chrome, Firefox, Safari).

  2. On Ubuntu it works fine on Firefox and Chromium, but is broken for Google Chrome.

So, I can reproduce this bug only on Google Chrome (Version 35.0.1916.114) on Ubuntu.


(Arpit Jalan) #5

Autocomplete for Emoji is also broken for Google Chrome (Version 35.0.1916.114) on Ubuntu. The problem is exactly same as I described for mentions. I am sure they both are related.


(Jeff Atwood) #6

@sam did your “quick fix” for long name autocomplete cause this issue?


(Sam Saffron) #7

very very unlikely, I just made the regex capture more letters


(Jeff Atwood) #8

OK so is this no-repro? I am not seeing any oddness with autocomplete. Or maybe it was a partial or failed deploy, or a CDN issue?

Also confirmed no issue at all on Chrome / Windows.


(Kane York) #9

I’m getting the same issue with both autocompletions.

Linux newlaptop 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:30:00 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Chrome from Google apt repository, Version 35.0.1916.114


(Jens Maier) #10

I’m not seeing any problems with Firefox (Mozilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0) or Chrome (Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.114 Safari/537.36) for either autocomplete list.

And my Chrome is the exact same version as @riking’s, too…


(Jeff Atwood) #11

@sam could it be the changes you made to keyboard shortcuts?

that does not explain why I see no issue on Chrome/Windows though.


(Kane York) #12

Chrome on Linux recently upgraded to the Aura branch, which changed all the text rendering and browser UI. Maybe this is related?


(Sam Saffron) #13

@techAPJ @riking no repro on the same system.

Can you try from an incognito window and see if it happens? Can you repro in dev?

I am strongly suspecting this is a timing issue.


(Kane York) #14

Recorded a video:


(Sam Saffron) #15

What happes if you run

Mousetrap.reset()

from console, does this go away?


(Kane York) #16

@sam nope, still no autocomplete


(Arpit Jalan) #17

Tried on incognito window, still happens. I can repro this on dev too.


(Sam Saffron) #18

Can you try a git bisect to find the commit that broke you. I am unable to repro this on my systems.


(Jeff Atwood) #19

@riking try removing or disabling the keyboard shortcut support locally and see if that changes anything.


(Arpit Jalan) #20

I tried to do git bisect, but for git bisect good, I was unable to find stable commit for which it was working, I tried to go as back as this commit:

https://github.com/discourse/discourse/commit/ab3ab26cc42a3bc9ebc3f1c8ddece97b2e0977c3

Then I pulled out my old Vostro notebook which has Ubuntu 14.04 installed with Google Chrome Version 34.0.1847.132, surprisingly the auto-completion is working perfectly fine on it for both mentions and emoji.

Now I am sure that this problem is happening only with Google Chrome Version 35.0.1916.114 on Ubuntu.

As @riking said, Chrome on Linux recently upgraded to the Aura branch, which changed all the text rendering and browser UI. Maybe this is the actual reason for this behavior?