Automatic activation for users

unsupported-install

(Bayo) #1

Hello everyone. I installed discourse on Azure using Bitnami.
I know this is not the supported way but I would be glad for some help.
I integrated the email and the test email works fine. But when a user signs up, activation email is not sent.
Other emails works just fine.
I have tried every method but to no avail.
Now I want my users to get activated on signup without the activation email.

Is there a way I can do that?

Thanks


(David Taylor) #2

To troubleshoot the email problems you can try following steps here:

These steps are obviously targeted at the standard install, but they might help.

What mail provider are you using?


(Rafael dos Santos Silva) #3

The fact that is unsupported, means that we can’t really help you, because the install can be broken in many ways that we no control whatsoever.

To do a supported install you can follow the official guide.


(Bayo) #4

Thanks for the help @David_Taylor . I would take a look at the links. I am using SendGrid


(Bayo) #5

Thanks for the reply @Falco . I would just like to know how to stop activation emails from being sent. I figured that wont be difficult, but I have been searching through the settings to find out how but cant seem to figure it out.


(Jay Pfaffman) #6

Discourse won’t work without confirming emails. A way around activation emails, though is to use social logins like Google, facebook and so on. Search

login #howto

(Cee Kay) #7

Dear, You should stop bitnami stack as soon as possible. I tried my level best with bitnami stack for discourse. It kept on crashing, it took me infinite hours to debug a little bug on the pure discourse code.

As @Falco said. You should try to install the supported install as mentioned in the dicourse github profile. It takes only a few minutes to get it up and running.

Btw, make sure you get KVM VPS(Digitial Ocran, Linode etc), if you are planning to move to the supported install.