Automatic backups not running


(Steven Greco) #1

I have had backups setup to run daily on my site for quite awhile but recently I have noticed that have not been running. No new backup files are being created. I looked into the log to see if there was anything there. No errors to speak of.

I then checked sidekiq and looked at the job there. In sidekiq the job is running with a status of success but it looks like it is running way to quick for a backup job.

What else can i do to troubleshoot this?

EDIT: to add kicking off a manual backup works correctly and a backup file is created.

Thanks


(Dean Taylor) #2

Usually free space is the culprit…

Make sure you have at least 2.5 times the space free that you would expect the backup to take up.

Usually you find the manual backup fails too, but I’ve found that taking any other action on the box may free some space and allow the manual backup to just about work.

For example, a machine restart, upgrade, rebuild, automatic background OS update etc. Conversely they may use more space.

So check the free space


(Steven Greco) #3

Wouldn’t that throw an error when trying to write the file or is that not
the case?


(Steven Greco) #4

fyi here is a breakdown of my space. Seems like i am good there.

xxxx@GrimReaperGamers:~# df -h
Filesystem                 Size  Used Avail Use% Mounted on
udev                       991M  4.0K  991M   1% /dev
tmpfs                      201M  372K  200M   1% /run
/dev/disk/by-label/DOROOT   40G   11G   27G  29% /
none                       4.0K     0  4.0K   0% /sys/fs/cgroup
none                       5.0M     0  5.0M   0% /run/lock
none                      1001M  1.2M 1000M   1% /run/shm
none                       100M     0  100M   0% /run/user
none                        40G   11G   27G  29% /var/lib/docker/aufs/mnt/cd73576a0bed96a27d47b0d4f5b31e3af94e792107309dc005dcd6cd351097e3
shm                         64M     0   64M   0% /var/lib/docker/containers/2f5cc4641bcb6a36b0ddbbcb6241942ed3a6b0068abc59444a7157fdb793c938/shm
xxxx@GrimReaperGamers:~# cd /var/discourse
xxxx@GrimReaperGamers:/var/discourse# ./launcher enter app
xxxx@GrimReaperGamers:/# df -h
Filesystem                 Size  Used Avail Use% Mounted on
none                        40G   11G   27G  29% /
tmpfs                     1001M     0 1001M   0% /dev
tmpfs                     1001M     0 1001M   0% /sys/fs/cgroup
/dev/disk/by-label/DOROOT   40G   11G   27G  29% /shared
shm                         64M     0   64M   0% /dev/shm

(Jay Pfaffman) #5

How about RAM? Do you have 2GB? Swap?


(Steven Greco) #6

Yeah RAM is good.

xxxx@GrimReaperGamers:/# free -m
             total       used       free     shared    buffers     cached
Mem:          2001       1916         85        174          3        241
-/+ buffers/cache:       1671        330
Swap:         2047        617       1430

(Dean Taylor) #7

Actually no it doesn’t for automatic backups, I’ve opened a bug on this ages ago.