Avatar,logo or any image URL is HTTP instead of HTTPS

(Amod Joshi) #1

he images uploaded on Discourse (our platform) are displayed on http port instead of https. The site becomes ‘not secure’. When we ‘force https’ in Admin Settings we face User Login issues (user not able to login - we have SSO).

We did not have this issue prior to update of Discourse.

(Stephen) #2

Enable force_https and make sure your SSO is configured for the HTTPS address.

Use of a certificate with force_https disabled is completely unsupported. This isn’t an avatar issue with force_https disabled, it’s an SSO issue that you need to pinpoint.

2 Likes
(Amod Joshi) #3

I tried what you said. I removed SSO and enabled force_https. I am not able to login to site using discourse login.

For more reference I am using lets encypt free ssl and configured in nginx server.
one more thing I want to know, how to monitor the error logs in ssh console of discourse
so that i will put that issue up in the forum.

(Stephen) #4

I didn’t tell you to disable SSO, I said you had to troubleshoot the SSO issue when HTTPS is enabled.

Have you forgotten your discourse login credentials?

(Jeff Atwood) #5

Use the /users/admin-login route if you can’t log in with busted SSO.

1 Like
(Amod Joshi) #6

I tried the route suggested but I got failure in too. It asked me the email address of admin
and sent the mail. When I click the url, It did not login but redirected me to main page.

Can you help me to debug?

(Amod Joshi) #7

Can you give us some pointers as to how I can troubleshoot / debug the SSO issue when HTTPS is enabled?

Below is the error file I see in admin login.