Avatars gone since last 100+ commits


(Sander Datema) #1

Last night I updated Discourse and I was 100+ commits behind. After that all avatars (multisite) were gone. Registering new accounts would also have no avatar.

Did I miss a new setting or requirement? I know about the changes in the avatar system, but that worked fine. Something in the last 100+ commits changed this. Even the automatically generated avatars don’t work anymore.

And no, nothing in the logs. :frowning:

BTW, I use Amazon S3, but all avatars now point to http://domain.ext/user_avatar/domain.ext/username/64/125.png, etc.


(Sam Saffron) #2

You need to rebuild, fixed this morning


(Sander Datema) #3

Solved it partially… Some users now have a profile picture of 1x1 pixels…


(Sam Saffron) #4

You certain this is not local caching?


(Sander Datema) #5

Don’t think so, and why would there be avatars of 1x1 pixel?

I tried rake avatars:clean and then rake avatars:refresh. But to no avail.


(Sam Saffron) #6

What happens when you look at the user profile, is the fullsize version there, is there a pattern, is it letter avatars ? gravatars ? uploaded avatars ?


(Sander Datema) #7

The user profile also has a 1x1 profile pic.

I created a new user and it got the correct letter avatar. Then tried to upload a custom avatar. After uploading, the image won’t show and in stead is a 1x1 pixel picture. So something goes wrong when editing profile pics.

Non of my users have a letter profile pic, but that one seems to be alright.

Hmm… there is an error in the logs now, just after I uploaded that picture:

SecurityError: The operation is insecure.
Url: http://domain.ext/assets/application-fc808bd78c0094ebe6cfa6f5ede23bb9.js
Line: 8
Window Location: http:/domain.ext/users/test/preferences

(Sam Saffron) #8

Have you tried ?

cd /var/docker
git pull
./launcher rebuild app

(Sander Datema) #9

Yep, did exactly that…


(Sam Saffron) #10

Does gravatar work properly?

Do uploads into composer work?


(Sam Saffron) #11

Can you try a rebuild with latest, fixed another regression in this area today.


(Sander Datema) #12

Had to restore everyone’s setting to use Gravatar instead of that silly one pixel, but yes, I think it’s solved now. Thanks.


(Régis Hanol) #13