Babble - A Chat Plugin [ARCHIVE]

(Carlo Kok) #367

(James Kiesel) #368

Alright, I’ve just merged the beta changes into master, and cautiously labelled this version 1.0.0 (if this update doesn’t warrant a major version change, I don’t know what does.)

Overall I’m quite happy with the experience I’ve tested through thus far, and it’s far and away better than the pre-widget version, so thanks to @eviltrout for making such a dramatic improvement, as well as helping me along with a few changes to core for this.

As ever, let me know what’s not working for you, or what could be improved.


@gdpelican great work! Two bugs that I found:

  1. the notification on top of the chat icon doesn’t go away when you open the chat box and view the message.

  2. When you login to discourse, it doesn’t go to the home page. Instead it defaults to hostname/babble/topics/default.json and shows json data. I should point out I am using the desktop css of my site on mobile, and not the default discourse mobile version. If you could fix this bug, that would be great :slight_smile:

(James Kiesel) #370

Er, I can’t seem to reproduce either of those things, and the second one in particular seems very odd to me. Have some more specific repro steps?


It seems there was a clash with another plugin, which is why this was happening. Thanks!

(| full stack virgin) #373

Good for you that you’re seeing the notification. As for my case i’m still not seeing any notification but from the chat thread there’s already an update. Hmmm…


They are not working perfectly but Im going to run it for a couple of days/weeks so I know the issue.

(| full stack virgin) #375

Hopefully, they’ll be able to add “who’s online” add-on to this beautiful plug-in. :smiley:

(Joe Seyfried) #376

Hm… looks like there’s new trouble inbound?

I got a

Error: Could not find module `discourse/lib/emoji/emoji-toolbar` imported from `discourse/plugins/babble/discourse/widgets/babble-composer

…maybe due to this?

(James Kiesel) #377

Okay let’s all acknowledge the irony in the room of someone with the handle @eviltrout constantly cratering the work of someone with the handle @gdpelican, like some sort of aquatic Wile Coyote gag.

I’ll fix this stuff up pretty shortly, I don’t believe it’ll be too bad.

EDIT: These fixes are now in the master branch. Let me know if you run into further issues. :gem:

(Joe Seyfried) #378

Oh, that one took discourse-babble down, too…

(James Kiesel) #379

Nah, I’m just having some real problems with /admin/upgrade on discourse-babble at the moment; have been for some time. I should probably report it as a bug to see if others are having similar issues, but launcher rebuild app has worked alright as a rescue every time.


Is running the latest version or is it outdated? I ask because I was trying to test out both desktop and mobile versions and ran into problems with mobile. I’m using an iPhone 6 Plus with Safari. My problem is that the text entry box doesn’t seem to show at the bottom of the last post, so I can’t type anything. If the test website is outdated then that makes sense that it’s not working. Here is a screenshot…

Edit: It seems that maybe the bottom tool box may be covering it. I tried touching the screen toward the bottom and got the keyboard to pop up, but it doesn’t work all the time.

(James Kiesel) #381

Thanks for the report. The test site runs the ‘beta’ branch of the repo, which is currently up to date with the latest master.

I’ll take a look at this one, it’s possible we may need a bit of a hack to get around the bottom nav bar here.

PS: If you want a wider chat window on desktop, you can do that using a custom css override:

.babble-menu .slide-in {
  500px !important;

(Tom Newsom) #382

I have a curious bug to report.

At some point in the past, when we disabled, removed and then later reinstalled babble, the chat channel topics vanished entirely from regular view. They’re not in /c/chat and they persist even after being “deleted” via the Admin “Chats” page.

Now, it’s causing interference with the Topic List Previews plugin, but cricially _only for admins. Not myself, who holds the “developer” credenetials, just for the other two regular Admins.

Line 88 in discourse-topic-previews/plugin.rb at master · angusmcleod/discourse-topic-previews · GitHub is where the error happens.

What I’d like to do is track down these weirdly-behaving chat topics and wipe all traces of them from discourse. I have no idea how.

I ummed and ahhed about which topic to post this in acutally.
@angus - have you ever seen this error with Topic List Previews?

(Tom Newsom) #383

Ah, managed to destroy the topic from the rails console. Everything looks OK now :slight_smile:

(| full stack virgin) #385

site went down after the recent update.

remove babble chat, and rebuild , site went up.

now, adding babble chat, rebuild but can continue the process


The plugin works, but I get two (422) Unprocessable Entity errors. The urls for the errors are the topic page and the channel page:



I have tested on two different instances. Is anyone else getting them too?

(Tom Newsom) #387

Okay, here’s a more concrete error (multiple counts of) that remains in my logs now that everything is behaving itself.

ArgumentError (wrong number of arguments (given 2, expected 1))
/var/www/discourse/plugins/babble/plugin.rb:439:in `can_see_topic?'

I can forward you the contents of the env tab if that would help?

(James Kiesel) #388

Thanks for the report; looks like that method signature changed at some point. I’ve fixed in the latest beta branch.