Babble - A Chat Plugin [ARCHIVE]


(James Kiesel) #511

Eek, hi everyone; thanks for the messages of support / grumpiness. I’m taking some time this weekend to get this up to speed. Updates soon.


(Matt Landseadel) #512

Uncaught Error: Compile Error: bind-attr is not a modifier Url: http://-----/assets/ember_jquery-60dedd1dca1d8b8ce48b6d0087db3b96f3149b9b5af2d0c7c6357967d29031fb.js Line: 17 C

Error: Compile Error: bind-attr is not a modifier
at t.compile (http://-----/assets/ember_jquery-60dedd1dca1d8b8ce48b6d0087db3b96f3149b9b5af2d0c7c6357967d29031fb.js:17:12379)
at t.e.compileStatement (http://-----/assets/ember_jquery-60dedd1dca1d8b8ce48b6d0087db3b96f3149b9b5af2d0c7c6357967d29031fb.js:16:9322)
at t.compile (http://-----/assets/ember_jquery-60dedd1dca1d8b8ce48b6d0087db3b96f3149b9b5af2d0c7c6357967d29031fb.js:16:10354)
at i.compile (http://-----/assets/ember_jquery-60dedd1dca1d8b8ce48b6d0087db3b96f3149b9b5af2d0c7c6357967d29031fb.js:14:20509)
at e.invokeBlock (http://-----/assets/ember_jquery-60dedd1dca1d8b8ce48b6d0087db3b96f3149b9b5af2d0c7c6357967d29031fb.js:18:4922)
at t.evaluate (http://-----/assets/ember_jquery-60dedd1dca1d8b8ce48b6d0087db3b96f3149b9b5af2d0c7c6357967d29031fb.js:16:5545)
at e.execute (http://-----/assets/ember_jquery-60dedd1dca1d8b8ce48b6d0087db3b96f3149b9b5af2d0c7c6357967d29031fb.js:18:4706)
at e.resume (http://-----/assets/ember_jquery-60dedd1dca1d8b8ce48b6d0087db3b96f3149b9b5af2d0c7c6357967d29031fb.js:18:4322)
at t.handleException (http://-----/assets/ember_jquery-60dedd1dca1d8b8ce48b6d0087db3b96f3149b9b5af2d0c7c6357967d29031fb.js:18:13082)
at e.handleException (http://-----/assets/ember_jquery-60dedd1dca1d8b8ce48b6d0087db3b96f3149b9b5af2d0c7c6357967d29031fb.js:18:16035)


(jakimfett) #513

For what it’s worth, I’ve got a discourse instance with a few users if you need to test alpha changes. Looking forward to getting this working for my users.


(Matt Landseadel) #514

Crap. Did I do something wrong?
I just saw on the Github that it says:
NB: If you’re running a recent version of Discourse (you should be!), you’ll need to track the beta branch instead of master. To do this, use the following git clone url in your app.yml:
- git clone -b beta GitHub - gdpelican/babble: Discourse Shoutbox plugin

My app.yml has the normal
- git clone GitHub - gdpelican/babble: Discourse Shoutbox plugin

Naturally, I’m fully up-to-date on Discourse: v1.8.0.beta2 +3

Is this why Babble is broken?


(James Kiesel) #515

No, Babble is broken because updates to Discourse have broken it. I am working on it now; ETA early this week.


(Fajfi) #516

If you found time please accept my join to your transifex team. I’d like to add there my polish translation.


(James Kiesel) #517

I’ve accepted you, thanks!

I’ve got some exciting stuff done over the weekend, and will hack through some final bugs tomorrow before pushing and merging into master.


#518

(James Kiesel) #519

Oh… yes. I’ve pushed up to the beta branch, but am waiting on feedback and merge for this PR to announce.

If I can grab some time this weekend I’ll remove the dependency on that PR and push up anyway. Thanks for your patience. <3.


(Panteen Pro-V) #520

Will you be able to have a look at the reason why babble does not work properly with Safari and Firefox? It seems that only Chrome works with it (slow though). Thanks


(DiscourseMetrics.com) #521

Seeing the same thing today, the chat window does not show on Safari.

My biggest request would be to fix the UI issue on mobile where the input field disappears when you type into it on Chrome. :slight_smile: There’s also some weirdness when it comes to scrolling. It seems to be scrolling the topic list at times, below the chat.


(DiscourseMetrics.com) #522

I’d be happy to donate for development, if it helps at all :slight_smile:


(James Kiesel) #523

Alright, I’ve pushed up the latest to master, which includes fixes for the latest Discourse. I’ll continue to maintain a beta branch going forward, but for now beta and master are the same.

This is a pretty major refactor, which will allow for a much better user experience for you and a much better dev experience for me going forward :palm_tree:. The major feature in this release is that more than one chat can now be present on page at a time, which means that we can toggle both full page and shoutbox modes, which can now work together or independently. This will also allow us to integrate private messaging and quick messages-style channels in the future.

I also have the guts for a ‘Who’s online’ feature in there, which I’ll pull out into the interface soon, as well as chipping away at any regressions I hear about.

The language has also changed some in this release, so if you’re a translator I’d appreciate some help getting that part back up to speed as well.

Thanks again for your patience, my day job has been (and will be) quite full-on for the recent past and near future, but I’m committed to keeping this project afloat as best I can.

I appreciate the offers of support and will be putting a donate link up onto the README shortly.


(Fajfi) #524

I’ve updated polish language.

This is pretty nice update. I found some issues:

Chat change link from normal to preview one (change url after reload whole site):

  • Images are huge
  • Youtube link missing

Is it possible to disable this feature on chat?


(Erlend Sogge Heggen) #525

I highly recommend https://opencollective.com/!


(Matt Landseadel) #526

@gdpelican Thanks for the plugin updates! I’ve almost got the chat working for our community.

I’m running into a bit of a setup issue…and perhaps it’s my lack of experience with discourse. On the Chats Admin page, I clicked “New Channel”. At first, the Permissions radio options are not selected. I typed in “Monthly Live Chat” into the Channel Title field. I am able to select “Groups” and choose various groups and Save. No problems.

But when I select Category and choose a category, it keeps saying “Unable to save that chat channel. Please try again.” I’m not sure what I’m doing wrong.

babble enabled: true
babble placeholder:
babble icon: bullhorn
babble category name: chat
babble page size: 100
babble remote post:
babble remote url:
babble full page: true
babble shoutbox: true

Thanks in advance!


(James Kiesel) #527

Does that category have a chat channel associated with it already? That’s the most likely cause of that error.

Failing that, try clearing out the custom field on the category manually with the following commands in your container:

/var/discourse/launcher enter app
rails c
category = Category.find_by(name: "<category_name>")
category.custom_fields['chat_topic_id'] # => ensure that this isn't nil, otherwise we have some other problem
category.custom_fields.delete('chat_topic_id')
category.save

(Matt Landseadel) #528

Thanks for the quick response. I think that was part of the issue, but we still have something going on. It DID have a chat topic id. And if I went to that category in Discourse, the Chat command was visible in the nav for that category. (However, it would just spin if I chose it.)

After I did the rails commands, The Chat command was no longer in the nav for the category.

I went back into admin and tried to create the channel. I tried two approaches:
Method 1:
Hit New Channel
Typed in a Channel Title of "Live Chat"
Hit Save.
Groups was auto-selected and trust_level_0 was auto-filled.
At this point, users can use the bullhorn icon and have chats in the window.
If I select Category and select a category, when I hit Save, it says “Unable to save that channel. Please try again.”

Method 2:
To try it a different way, I deleted the channel and confirmed the rails steps again.

Then I clicked New Channel
Selected Category.
Choose the “Monthly Live Chat” category and then Save.
It auto-named the Chat Channel to the category name of "Monthly Live Chat"
If I click on Groups and try to assign groups, it gives the same error.

Am I misunderstanding the interface or is there a problem?
Can it only be by Category or by Group?

Thanks in advance!


(Matt Landseadel) #529

Also…Method1 - I have a bullhorn and users can have chats in the window, but not full screen chats.

Method2 - this time seems to have let me have the full screen when I go to the “Monthly Live Chat” category. AND the bullhorn is showing, so I think things are working…but that admin interface has me confused.

Thanks!


(James Kiesel) #530

Yep, the intended functionality at the moment is that Groups appear only in the shoutbox, whereas channels appear in the shoutbox and as an option of their respective category page.

The reason for this is that we’re on a path towards deprecating / removing the Groups feature, and having channels be the only thing associated with chats. (In fact, we’ll end up with a simple ‘Create Chat Channel’ button which secretly creates an associated public or private category in the background).