Babble - A Chat Plugin [ARCHIVE]

(Tomek) #611

It seems the newest beta does work well with IE, thanks.

Unfortunately there is another bug - you cannot close the chat window on topics (it works fine on homepage).

(Tomek) #612

I can confirm this, it does not work even though the translation seems to be finished.


Is there any way to change the colors of users based on group in the shoutbox? For example, Admins names would be red in the shoutbox, moderators would have purple names, etc?

(Robin) #614

We’re also having issues with the shoutbox on our community. It get stuck a lot, and on mobile the textbox sometimes does not show for some reason. I’ve found that if you are inside of a topic or personal message (instead of the homepage), the shoutbox gets sticky and won’t close.

I have enabled the full-screen chat while still keeping the shoutbox active. I asked the community members to use both and see which they prefer. The full-screen is a clear win at the moment. The only downside is that you don’t have an icon in the notification bar like you do with the shoutbox. As a workaround, I’ve edited the CSS as @fearlessfrog suggested and added a link to my chat category.

I think a great improvement to the full screen category chat would be a way to configure an icon in the header that also has the unread messages count for that chat like the shoutbox has.

(Johnny) #615

@gdpelican Babble is not working anymore. although its enabled but i cannot see the chat icon on the header. discourse version is 1.7.4

(James Kiesel) #616

Hm, I have somewhat regularly put in PRs to core to support Babble functionality, which may not be backported to the stable 1.7.4 release. Have you tried on the latest version of Discourse?

(Johnny) #617

@gdpelican I recently updated it, and now the version is v1.7.4 +6. but still babble seems disabled though its enabled.

(James Kiesel) #618

Sorry, but 1.7.4 isn’t the latest version; you’ll have to grab something in the 1.8.0beta flavour to get code recent enough to run Babble.

( #619

Is this the same issue you are seeing? Babble composer already active or could not be found · Issue #219 · gdpelican/babble · GitHub

(Albert Westra) #620

Do happen to have the Feature voting plugin install as well?

(Joe Seyfried) #621

Is there any news on this one? Can we help, is there a repro, something else?

(James Kiesel) #622

I have a fix, but I needed to make a slight change in core:

So hopefully once that’s merged we’ll be good to go again.

(Johnny) #623

@gdpelican I got an update and now the version is 1.7.6, but same issue. there is no babble chat icon.

Open shortcuts from keyboard in Firefox 52.0.2
( #624

You need to be on 1.8.0beta+ :slight_smile:

(Johnny) #625 so babble does not work on stable versions?

(cpradio) #626

The latest commit of Babble will not work with Stable versions of Discourse. You’d have to figure out which commit further back “could” work with it, and that’d be a lot of guess work.

Associating plugin versions with Discourse versions
(Albert Westra) #627

Just letting you know I’ve completely updated discourse(1.8.0.beta9) and babble(2.0.3), and shout-box is still not showing up in the header.

(James Kiesel) #628

Hm. I can confirm that Babble works on the latest versions; I keep up to date with pretty much the latest versions of everything, so if it works there, it should work on yours as well.

Core just merged a fix yesterday to fix a nasty bug with the chatbox not closing properly, so I’d encourage an update to the latest bleeding edge for Discourse (1.8.0.beta9+17 at the time of this writing) and try again.

Another possible thing is that there was a report a bit back of a conflict with the Feature Voting plugin which I haven’t had a chance to investigate yet; I’ll report back on that one this weekend. :pineapple:

( #629

Nice job @gdpelican, look forward to testing the latest fix :slight_smile:

(Johnny) #630

@gdpelican hi can you please besides the latest version of discourse, can you also release babble for the stable versions? because babble does not work on stable versions e.g. I have version 1.7.6 and babble does not work. I have been facing this problems for past many weeks.