Back button after posting does not go back


(Kevin P. Fleming) #1

I’ve now gotten into the habit of using the browser’s back button to return to the “Unread” or “New” lists, as has been thoroughly discussed elsewhere on this forum. It works well enough that I have no complaints.

However, some time in the last week or two, the behavior has changed if I reply to a topic: clicking ‘back’ then takes me back to the same topic page (essentially a refresh), and a second ‘back’ takes me back to the topic list where I selected the topic originally.


Back is not always taking me to the correct page
(Jeff Atwood) #2

What browser and OS? Have not seen this. Can you repro it on try.discourse.org?


(Kevin P. Fleming) #3

OSX, with Chrome 29.0.1547.65. I was just able to reproduce on try.discourse.org.

  • Logged in
  • Selected the ‘A bear, …’ topic from the topic list.
  • Scrolled to the bottom of the topic.
  • Clicked the blue Reply (to topic) button.
  • Composed my reply and hit Reply button.
  • Page refreshed with my reply.
  • Hit browser back button; page refreshed again, same content (including my reply).
  • Hit browser back button again, returned to topic list.

(Jeff Atwood) #4

I don’t have any OSX to test this on. @neil?


(Neil Lalonde) #5

I’m seeing this too, except I don’t see any full page refreshing. Basically, I have to hit the back button twice to get to the topic list if I reply to a topic. I guess it’s kinda annoying.


(Luke S) #6

I’m seeing this on Windows 7 professional, as well. Chrome 29.0.1547.66

I wouldn’t call it a full page refresh, either. Just reloads the topic.


(Jeff Atwood) #7

Yep confirmed in Chrome latest, Windows. This is definitely some kind of bug @eviltrout.

Not super urgent, but worth a look when you have time.


(Jeff Atwood) #8

I think we fixed this. Flag if incorrect.


(Jeff Atwood) #9