# Backup is failing due to bad HTTPS

**URL:** https://meta.discourse.org/t/backup-is-failing-due-to-bad-https/113041
**Category:** Support
**Tags:** unsupported-install
**Created:** [3월 31, 2019, 5:11오전 UTC](https://meta.discourse.org/t/backup-is-failing-due-to-bad-https/113041 "2019-03-31T05:11:11Z")
**Posts on this page:** 1
**Showing post:** 14

<div class="post-metadata">

### Author: ![azawawi](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/azawawi/32/135777_2.png) [@azawawi](https://meta.discourse.org/u/azawawi)
#### Post date: [4월 1, 2019, 12:45오후 UTC](https://meta.discourse.org/t/backup-is-failing-due-to-bad-https/113041/14 "2019-04-01T12:45:17Z")

</div>

@pfaffman That commit basically broke my minio discourse s3 backup today after upgrading to the latest (2.3.0-beta6). The following resolved it after spending 2 hours fixing it:

- Add a DNS entry for your `backup-bucket-name.backup.example.com`.
- Add a `MINIO_DOMAIN` environment variable to your `/etc/default/minio` file.

```plaintext
MINIO_DOMAIN="backup.example.com,backup-bucket-name.backup.example.com"

```

- In case you are using Let’s Encrypt for minio SSL certificates:
  - Expand your SSL certificate by adding another `-m backup-bucket-name.backup.example.com` certbot command argument.
  - Restart minio service after copying / symlinking your SSL certificates.

```plaintext
systemctl restart minio

```

---

_[View the full topic](https://meta.discourse.org/t/backup-is-failing-due-to-bad-https/113041)._
