# Backup is failing due to bad HTTPS

**URL:** https://meta.discourse.org/t/backup-is-failing-due-to-bad-https/113041
**Category:** Support
**Tags:** unsupported-install
**Created:** [3월 31, 2019, 5:11오전 UTC](https://meta.discourse.org/t/backup-is-failing-due-to-bad-https/113041 "2019-03-31T05:11:11Z")
**Posts on this page:** 1
**Showing post:** 16

<div class="post-metadata">

### Author: ![azawawi](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/azawawi/32/135777_2.png) [@azawawi](https://meta.discourse.org/u/azawawi)
#### Post date: [4월 1, 2019, 2:47오후 UTC](https://meta.discourse.org/t/backup-is-failing-due-to-bad-https/113041/16 "2019-04-01T14:47:47Z")

</div>

@hosna Not really sure. What is your Discourse version?

For my configuration, I only upload my discourse backups to another minio s3 server. When I upgraded to 2.3.0.beta6, Admin / Backups started giving an “Internal Server Error” message box. It turned out that it was not actually resolving the `bucket-name.backup.example.com` domain (DNS-style instead of path-based Bucket naming). **It is now working as expected for my minio s3 configuration.** 😓😄

### References:

- Related pull request: [#7210, DEV: Remove SiteSetting.s3\_force\_path\_style](https://github.com/discourse/discourse/pull/7210).
- Related post: [S3 migrations from/to minio problems - #41 by rishabh](https://meta.discourse.org/t/s3-migrations-from-to-minio-problems/97333/41).
- Related minio issue: [Support for DNS style S3 Bucket naming](https://github.com/minio/minio/issues/4681).
- [Minio Server Config Guide](https://docs.minio.io/docs/minio-server-configuration-guide.html).

---

_[View the full topic](https://meta.discourse.org/t/backup-is-failing-due-to-bad-https/113041)._
