Hi guys, I got this error when I execute this:
xxx@DESKTOP-LICQPFO:~/discourse$ bundle exec rake db:create db:migrate
Discourse requires Ruby 2.5.2 or up
ruby 2.5.1p57 (2018-03-29 revision 63029) [x86_64-linux]
I updated ruby to 2.5.3 but then I got another error when I run bundle install:
Warning: the running version of Bundler (1.16.1) is older than the version that created the lockfile (1.17.1). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.
Fetching gem metadata from https://rubygems.org/.........
Using rake 12.3.1
Using concurrent-ruby 1.0.5
Using i18n 1.0.1
Using minitest 5.11.3
Using thread_safe 0.3.6
Using tzinfo 1.2.5
Using activesupport 5.2.0
Using builder 3.2.3
Using erubi 1.7.1
Using mini_portile2 2.3.0
Fetching nokogiri 1.8.5
Installing nokogiri 1.8.5 with native extensions
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.
current directory: /home/xxxx/discourse/vendor/bundle/ruby/2.5.0/gems/nokogiri-1.8.5/ext/nokogiri
/usr/bin/ruby2.5 -r ./siteconf20181111-13645-a4zobf.rb extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h
extconf failed, exit code 1
Gem files will remain installed in /home/xxxx/discourse/vendor/bundle/ruby/2.5.0/gems/nokogiri-1.8.5 for
Results logged to
An error occurred while installing nokogiri (1.8.5), and Bundler cannot continue.
Make sure that `gem install nokogiri -v '1.8.5'` succeeds before bundling.
actionmailer was resolved to 5.2.0, which depends on
actionpack was resolved to 5.2.0, which depends on
actionview was resolved to 5.2.0, which depends on
rails-dom-testing was resolved to 2.0.3, which depends on
I ran gem install bundler nothing changes, I still have the warning message saying Warning: the running version of Bundler (1.16.1) is older than the version that created the lockfile
I ran gem install nokogiri -v ‘1.8.5’ but it generated another error:
xxxx@DESKTOP-LICQPFO:~/discourse$ gem install nokogiri -v '1.8.5'
Building native extensions. This could take a while...
/home/xxxx/.rbenv/versions/2.5.3/lib/ruby/2.5.0/rubygems/ext/builder.rb:76: warning: Insecure world writable dir /home/xxxx/.rbenv/versions in PATH, mode 040777
Any help would be appreciated, thanks.