Bitnami installation for newbies

unsupported-install

(Serhat Kapusuz) #1

Hi

İ saw discourse today from social media and i really like it. when i checked installion guide it was too complex for me. İ always worked with wordpress, envato, php scripts etc… easy stuff. but i searched bitnami for installattion on discourse. is it really working ? ( one click and install)

Version number is Version 1.5.3 on bitnami. can i upgrade with no problem after installation ? i think i will translate it Turkish because i didnt found language package

Thank you in advance for helping.


The cheapest solution for hosting?
Bitnami → Dockers
(Erlend Sogge Heggen) #2

Bitnami is not officially supported until they support our Docker-based installation:

You might have trouble updating to the latest versions if you use Bitnami today.


Any difference with installation via ssh or bitnami?
(Jay Pfaffman) #3

Digital ocean has One click install. I haven’t tried it, but I think it works. I think the downside is that requires a more expensive droplet.


(Serhat Kapusuz) #4

i think i found it but is it working ?

https://www.digitalocean.com/community/tutorials/how-to-use-the-discourse-one-click-application-on-digitalocean


(Erlend Sogge Heggen) #5

Yes, it should be. And DO charges by the minute, so you can try out the installer, see if you get it working, and if you find that it’s too bothersome you can just leave it and it’ll have cost you less than $1


#6

I received an email today that says that Dockers is available. That email/newsletter has this link →
https://bitnami.com/containers

What does this means now bitnami can be auto installed with the dockers and the update will also be possible.


(Rafael dos Santos Silva) #7

There is no Discourse in that page, so no.


#8

Can bitnami install the latest discourse that can be updated?


(Jeff Atwood) #9

I doubt it, because their packaging isn’t Docker based. But it is good they are updating versions!


#10

Is there a way to Know if their packaging is docker based?


(Jeff Atwood) #11

It has never been in the past, so unless they changed their entire packaging model overnight, it is supremely unlikely. Feel free to email them and ask.


#12

I have already emailed them, but they take ages before they reply.


#13

Do you think that the above is suitable for Discourse software→


(Jay Pfaffman) #14

Sure. But it’s much easier to configure Digital Ocean. Have you seen the install docs?.


#15

DO costly for new business.


(Jeff Atwood) #16

It’s $10/month for Digital Ocean. If that is outside your budget, I suggest that you should not be considering Discourse, which requires 1GB RAM and a reasonably fast modern CPU. A traditional PHP forum would be a better fit for extremely limited budgets, as they can work on 256MB RAM servers with older CPUs.


(Jeff Atwood) #21