Blank pages after upgrade


(Shane Dobson) #1

I’ve just tried to upgrade discourse to the latest version. I’ve done this on a clone of our live box because we have had a multitude of problems and I don’t want to risk breaking the live instance. I used the upgrade process of running these commands:

cd /var/discourse
./launcher bootstrap web_only
./launcher destroy web_only
./launcher start web_only

This didn’t work on our live instance by the way - it broke discourse completely and I had to create a new machine from backups to get it working again.

However on the clone instance it appears the upgrade has worked - but when I try to access the URL the page is completely blank. The browser seems to connect because I can even view the certificate for the site, but the page is blank.

Incidentally the reason we are trying this is because our emails recently stopped sending for no apparent reason, and we have not been able to upload images to our forum for about a month now. This used to work, nothing was changed, and suddenly image uploads hang at 100% and nothing happens.

So basically, a lot of problems, but if I could solve the blank page issues then I can at least see if image uploads and emails work on the new version.

Can anyone help? Discourse hasn’t worked the way we need it to (and had it working before) for over a month now and it’s starting to impact really heavily on us.


(Jeff Atwood) #2

This usually means your plugins are incompatible with the new version. Disable all third party plugins and rebuild.

You can also check the browser console with f12 to see if the errors there tell you anything.


(Shane Dobson) #3

This may seem like a stupid question, but I am new to discourse and taking over an instance installed by someone else. How can I disable a plugin? F12 reveals nothing out of the ordinary.


(OG) #4

Basically just remove them from /plugins directory…


(Shane Dobson) #5

I tried that - removed them and rebuilt the app but after the rebuild they were back again.

In the end I bit the bullet, upgraded our production instance. This worked fine and it fixed the emails not sending issue. The issue with the file uploads was to do with out S3 credentials failing so not a discourse issue.

Worth noting that when upgrading our production instance (which has all the same plugins as the clone instance of course), this blank page issue didn’t occur, so it wasn’t the plugins whatever the problem was. I say this is important to note because the answer to almost every issue that people raise on here seems to be “delete your plugins”.


(OG) #6

Deleting plugins is the first step to isolate and identify underlying problem.

In your case you would need to remove plugins also from app.yml because they are installed when boostrapping.


(Vinoth Kannan) #7

To remove plugins edit /var/discourse/containers/web_only.yml (app.yml file in many cases) file and remove your plugin related lines. You can see those in bottom like below

hooks:
  after_code:
    - exec:
        cd: $home/plugins
        cmd:
          - git clone https://github.com/discourse/docker_manager.git  # BASIC PLUGIN - DON'T REMOVE
          - git clone https://github.com/example/plugin.git  # PLUGIN 1 -- REMOVE THESE LINES
          - git clone https://github.com/demo/plugin_2.git  # PLUGIN 2  -- THIS TOO
          - git clone https://github.com/another/example-plugin.git  # PLUGIN 3 -- ALSO THIS