Blank screen after https registration with original release of IE11


(Daniel Hollands) #1

I’ve had reports from some of the users on Birmingham.IO that they’ve been unable to register for an account using IE:

It give me all the green ticks to say that everything is OK, then I click ‘create new account’ and it just goes to a blank screen

After this I looked in the admin for their user account, but nothing was there, suggesting that the call to the API failed or something. They tried again using Chrome, which worked.

Alas, I don’t have access to IE to test this myself.


(Daniel Hollands) #2

Quick update, I’ve just tried to sign up using an Windows 11 on a virtual machine, and I’m getting the same issie, both on my site, but also here at meta.


(Jeff Atwood) #3

I cannot reproduce this in IE11 touch mode on surface pro 3. I was able to register a new account just fine on try.discourse.org as expected.

I also cannot reproduce in this desktop IE11 on try.discourse.org either.

Can you describe your steps in more detail? Can you create a new account in IE on try.discourse.org?

And in the interests of complete disclosure, we barely support IE9, so it’d need to be IE10 or newer.


(Daniel Hollands) #4

I’m not sure what to tell you. I can’t tell you any more about the user other than what I’ve said so far (although looking at the screenshot, it looks like IE11 running Win 8.1).

As for me, I loaded up the IE11 Win8.1 VM from https://www.modern.ie/en-us/virtualization-tools, went to the site, hit sign up, completed all the questions (getting all the green ticks as I went) then upon hitting submit button, i get redirected to a blank screen. This happened on both Birmingham.IO and this site.


(Jeff Atwood) #5

Does it happen on try.discourse.org?


(Jeff Atwood) #7

Screenshots of me creating that account here on meta.discourse in IE11:


(Daniel Hollands) #8

It doesn’t work for me on Birmingham.IO or meta, but does work on try… no idea why.

I filmed the process so you can see for yourself (it’s still processing, so might not be available right away):


(Jeff Atwood) #9

I guess there is something between you and us interfering with the process? Proxy? Anti-virus software on your machine?

We have zero reports of this happening for anyone else.


(Daniel Hollands) #10

Are meta and try on the same server? Why would it work for one, and not the other?

Not that I’m aware of, as I said, it’s a bare bones VM provided by microsoft.

Not to get pedantic :stuck_out_tongue: but it’s two reports - myself, and the user which first highlighted this issue to me. I have no idea why you can’t replicate it, but I can.


(Jeff Atwood) #11

No repro for me on birmingham.io… is your virtual machine interfering? Can you try a real windows box like mine?


(Dean Taylor) #12

I have just tested this and unable to reproduce on the following machines:


(Dean Taylor) #13

Reproduced problem - inside Microsoft Virtual PC - using Windows 7 IE11 (11.0.9600.16428) running on Windows 7 native.

Output page source here:

Virtual PC extensions were not installed.


(Dean Taylor) #14

Inspection view


(Jeff Atwood) #15

Fascinating. So something about being inside a virtual machine is interfering with login on IE11. No idea what that could be.


(Dean Taylor) #16

Could it be a cookie or session issue…
If you visit the URL in an incognito window you get the same output: Community


(Jeff Atwood) #17

@techapj can we add more diagnostics to this page, so something happens when you load it in incognito mode? Or just clicking on it?

I can’t find any bugs or issues here, every time we try to sign up with IE11, on every single site, it works. But more diagnostics would be good. Blank pages not so good.


(Dean Taylor) #18

Here is a complete Fiddler session for failure on that Virtual PC - Windows 7 IE11:

You want the larger file if you want the whole session, smaller file is just the submission and response of the signup.


(Dean Taylor) #19

On the failing virtual machine I completed the Windows Update cycle:

  1. Check for Windows Updates
  2. Download Windows Updates
  3. Install Windows Updates
  4. Restart Computer
  5. Go to 1 - until no more required updates

This resolved the issue and now correctly displays the page:

So we went from IE11 11.0.9600.16428 to IE11 11.0.9600.17358

Somewhere in the rainbow of patches is a fix for this issue.

EDIT: yes the windows update cycle took 2 hours.

@limeblast Ask your user to run Windows Update


(Jeff Atwood) #20

Wow amazing detective work! I think this merits a Discourse T-shirt at minimum. Pm incoming.

I really should have thought to check the ie version. Shame on me.


(Daniel Hollands) #21

This is excellent, thank you @DeanMarkTaylor :slight_smile:

I’m still confused as to why try worked, while meta and Birmingham.IO didn’t, but this is a step in the right direction.

I’ll run Windows update in the VM and see what happens, and ask my user to run Windows Update too (although I don’t think she’s inside a VM, but it would not surprise me if she was a patch or two behind on Windows).