Blank white page after update

Hi friends,

I updated and now i have a blank page on my discourse :
I can see these errors in the console :

_ember_jquery-9c4852b….js:3464Uncaught TypeError: Cannot read property 'startRouting' of undefinedstartRouting 

@ _ember_jquery-9c4852b….js:3464didBecomeReady @ _ember_jquery-9c4852b….js:4124invoke @ _ember_jquery-9c4852b….js:885flush @ _ember_jquery-9c4852b….js:950flush @ _ember_jquery-9c4852b….js:755end @ _ember_jquery-9c4852b….js:180run @ _ember_jquery-9c4852b….js:235join @ _ember_jquery-9c4852b….js:254u.join @ _ember_jquery-9c4852b….js:15143(anonymous function) @ _ember_jquery-9c4852b….js:15205l @ _ember_jquery-9c4852b….js:3fireWith @ _ember_jquery-9c4852b….js:3ready @ _ember_jquery-9c4852b….js:3

Failed to parse SourceMap:

I cleanup old dockers, and i rebuild the app, i restarted the server but nothing changed. Can you help me ?
Thank you

Do you have at least 2gb of swap set up on your server? If you do not, update can fail due to out of memory.

Could someone write a check during the update? If there’s not enough swap memory, then it doesn’t start the updating.



I have 4GB of RAM and 2GB of Swap… Swap is not yet used…

Edit : I updated again the app and now it works. Thank you !


A post was split to a new topic: White screen for certain languages

I am also getting a white blank page following the latest update.
The site is showing using Safari but is not appearing in Chrome or Firefox

Im not seeing any errors on the console, here’s the output from top.

top - 13:08:09 up  1:16,  1 user,  load average: 0.09, 0.51, 0.54
Tasks: 167 total,   1 running, 166 sleeping,   0 stopped,   0 zombie
%Cpu(s):  8.8 us,  2.0 sy,  0.0 ni, 88.2 id,  0.3 wa,  0.0 hi,  0.7 si,  0.0 st
KiB Mem:   1015184 total,   999940 used,    15244 free,     6564 buffers
KiB Swap:  2097148 total,   703736 used,  1393412 free.   125980 cached Mem

I’ve tried appending ?preview-style=none but with no effect.

Any ideas?

Interesting - happening to me just now on an older Android phone and thought it was a site error, but maybe this is a general issue?

It appeared to be working with no issue until I logged into my site about 20-30 minutes ago. I thought it might have something to do with the scripts running when you log in (I was waiting to screencapture the “add to homescreen banner” prompt for the site instructions)

I am using a Galaxy S3 with the built-in browser

1 Like

I logged in using Safari and disabled custom styles which seems to do the trick.

We disabled custom styles too and it seems to have fixed some loading issues but not all - the logo in the header no longer brings you to the home page

Wow, uh, you’re using 700MB of swap. I think it’s time to add more RAM to that box.


Blank page issue happens to me as well.
After cleaning cache of my browsers, all of them show blank page now…

Try doing the following. Rebuild the app via docker and If you are using a proxy like cloudflare, purge all cache. Do the same on your browser too. This fixed the blank page for me.

If it doesn’t work post your console errors if any on your browser.


I end up solve by setting app.yml, set version to stable instead of testpassed
and then ./launcher rebuild app


In my case, behind a reverse proxy, it was related to the pagespeed module which was enabled…

1 Like

Thanks for that tip! I will try to find out if you can disable pagespeed for only one domain and leave it on for others.

This solved my issue, I wonder if there is any side effects.

1 Like

Had the same issue and @Wesley_Chia_Wei_Lin solution fixed it.Thanks Wesley.