Blurring of text while and after scrolling (Google Chrome)


(Patrick Klug) #1

Since upgrading to Discourse 1.0 I notice some very distracting and ugly text blurring when scrolling inside a topic. This doesn’t seem to happen on the front page itself but only when reading topics.

Example:

Seems to me that text rendering jumps from sub-pixel rendering to rasterized and back again.

Is there some ‘smooth-scrolling-animation’ that you guys employ that causes this?

Using Google Chrome 38.0.2125.24 beta-m


(Theron Boerner) #2

Is this on windows? I’ve noticed that windows and chrome handle scrolling and animations a lot differently.


(Jeff Atwood) #3

We do not support beta browsers.

I don’t see any strangeness with rendering in the released version of Chrome.

Also, we do not use any special scrolling code.


(Patrick Klug) #4

same thing happens with Chrome Version 38.0.2125.24 unknown-m - anyway, seems like a browser issue :frowning:


(Zane Beckman) #5

I’m on Version 37.0.2062.94 unknown-m (64-bit) and I’m not experiencing this.

I’ll update and report back.

My gut instinct is that it’s a driver issue. Try disabling gpu rendering in settings and see what happens.

Edit: Updated to Version 37.0.2062.102 unknown-m (64-bit) (stable) and I’m still not able to reproduce.


(Rikki Tooley) #6

The Windows version of Chrome switched to the DirectWrite API for font rendering recently, to support High DPI screens… that might be the cause. Text rendering in Chrome was horrible before anyway.


(Patrick Klug) #7

about time that they switch to DirectWrite. Unfortunately (for discourse users) this seems to be the cause of this issue. Turning off GPU acceleration fixes the problem.


(Jeff Atwood) #8

I suggest updating your video drivers if you can – I did not see any glitches with DirectWrite even in the previous version when this feature was in beta


(lid) #9

I just recently updated to the latest chrome 37.x

My experience is a little bit different.

On Discourse, After the update everything renders bigger: fonts and chrome UI elements(Address bar).
Here is a screenshots comparing version 36 vs 37

###Version 36

###Version 37 ( losing some good real estate here)

This is not on discourse, but it is evident that the new font rendering is still not stable.
rapid Mouse hover not even scrolling in this screen capture shows fonts rendering go wacky and blurry

This is obviously a Google chrome issue and not discourse. DirectWrite is still experimental.


(Rikki Tooley) #10

Yeah, that’s the high dpi screen support. Before you had the option of tiny UI, or normal-sized but blurry UI. I guess now you just have the option of big UI :smile:

Firefox has always worked better in this respect :wink:


(lid) #11

I didn’t mind the smaller text or smaller UI. things were sharp and clear. And looked decent on 17" and it is more natural to zoom in then zoom out to see a website.

Now the ui is bigger. Text is blurry at times
Specially on the developers tool.

I could have said that bigger ui and text may strain my eyes less but the blurry font force my eyes to focus harder.

And the registry hack to force hidpi support does not work. The registry defaults to 2(no support) every time I restart chrome.

Hope things will be more flexible on future releases


(Sam Saffron) #12

(Luke Larris) #13

@sam Drastic measures for such a small issue.


(Sam Saffron) #14

this is not a small issue, I spend 5 minutes going, what the heck, am I losing my eyesight?


(lid) #15

Adding the following to chrome shortcut did the trick for me on the 37 branch (windows 8 , 1080 screen).
close all chrome process and restart.

/high-dpi-support=1 /force-device-scale-factor=1

It pretty much restore chrome to what I use to have (smaller text, and smaller UI) , and the best part no more headache due to blurriness.

It is unfortunate that chrome is failing miserably handling this. I must admit that if I couldn’t find a working workaround I would have too dump chrome to the garbage.


(Yv Rao) #16

Windows Registry editing fixed the font thickness issue for me completely, we can tune the font thickness/darkness by calibrating FONTSMOOTHINGGAMMA value to between 150 and 190 hexadecimal( 336 to 400 decimal )

  • START -> RUN -> REGEDIT
  • search for FONTSMOOTHINGGAMMA by keying “Ctrl F”
    ( will automatically take us to CurrentUser\ControlPanel\Desktop path)
  • double-click mouse on FONTSMOOTHINGGAMMA enter any
    thing between 150 and 190 hexadecimal.
    (the Lower the value, the thicker the fonts.)
  • close the REGEDIT tool
  • LOGOFF and then LOGON

Now all the fonts are very thick & very dark in Chrome Browser.

But we must make sure that ClearType smoothing is enabled in Windows( controlPanel -> personalization -> appearance -> Effects -> ClearType smooth check (ticked box) )

                     OR  alternately in RegEdit ...

         FONTSMOOTHING=2
         FONTSMOOTHINGTYPE=2
         FONTSMOOTHINGORIENTATION=1  for LCD-screen,  0 for CRT-screen

(Patrick Klug) #17

this seems to have fixed itself on my machine. running Chrome 38.0.2125.104 m no longer shows the problem, even though I’m running high DPI settings on Windows and have hardware acceleration turned on. I did notice, however, that the Chrome window-chrome is no longer using the high DPI settings so I assume chrome works around this now.


(Jeff Atwood) #18