# Bootstrap failed after rebuild - changed domain name

**URL:** https://meta.discourse.org/t/bootstrap-failed-after-rebuild-changed-domain-name/28206
**Category:** Support
**Created:** [May 1, 2015, 4:29pm UTC](https://meta.discourse.org/t/bootstrap-failed-after-rebuild-changed-domain-name/28206 "2015-05-01T16:29:09Z")
**Posts on this page:** 10
**Page:** 1

<div class="post-metadata">

### Author: ![wcr](https://avatars.discourse-cdn.com/v4/letter/w/77aa72/32.png) [@wcr](https://meta.discourse.org/u/wcr)
#### Post date: [May 1, 2015, 4:29pm UTC](https://meta.discourse.org/t/bootstrap-failed-after-rebuild-changed-domain-name/28206/1 "2015-05-01T16:29:09Z")

</div>

I have attempted to follow the instructions listed [here](https://meta.discourse.org/t/change-the-domain-name-or-rename-my-discourse/16098) to change the domain name of the installation. All went well until the rebuild. Here are the results of the rebuild app:

BTW I know only a tiny bit about ssh…

```
root@discuss:/var/discourse# ./launcher rebuild app
Ensuring discourse docker is up to date
Fetching origin
Discourse Docker is up-to-date
Stopping old container
+ /usr/bin/docker stop -t 10 app
app
cd /pups && git pull && /pups/bin/pups --stdin
From https://github.com/SamSaffron/pups
   8d972ab..7d741e1 master -> origin/master
Updating 8d972ab..7d741e1
Fast-forward
 README.md | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)
I, [2015-05-01T16:23:58.782133 #41] INFO -- : Loading --stdin
/pups/lib/pups/merge_command.rb:45:in `merge': no implicit conversion of String into Hash (TypeError)
        from /pups/lib/pups/merge_command.rb:45:in `deep_merge'
        from /pups/lib/pups/cli.rb:21:in `block in run'
        from /pups/lib/pups/cli.rb:18:in `each'
        from /pups/lib/pups/cli.rb:18:in `run'
        from /pups/bin/pups:8:in `<main>'
f5ce36899454a37636c3fddad3c4230f306768355b5fa941aea2cceabc42ba62
FAILED TO BOOTSTRAP
root@discuss:/var/discourse#

```

---

<div class="post-metadata">

### Author: ![sam](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sam/32/102149_2.png) [@sam](https://meta.discourse.org/u/sam)
#### Post date: [May 1, 2015, 9:23pm UTC](https://meta.discourse.org/t/bootstrap-failed-after-rebuild-changed-domain-name/28206/2 "2015-05-01T21:23:40Z")

</div>

you have invalid yaml, its parsing but semantically incorrect, what is your app.yml sans passwords.

---

<div class="post-metadata">

### Author: ![wcr](https://avatars.discourse-cdn.com/v4/letter/w/77aa72/32.png) [@wcr](https://meta.discourse.org/u/wcr)
#### Post date: [May 2, 2015, 12:41am UTC](https://meta.discourse.org/t/bootstrap-failed-after-rebuild-changed-domain-name/28206/4 "2015-05-02T00:41:16Z")

</div>

Yes…I edited the app.yml in order to change the domain. I also edited the mandrill section, to match what was in my madrill settings. I am sure I screwed something up here…

```
    ## After making changes to this file, you MUST rebuild for any changes
## to take effect in your live Discourse instance:
##
## /var/discourse/launcher rebuild app
##
## Make sure to obey YAML syntax! You can use this site to help check:
## http://www.yamllint.com/

## this is the all-in-one, standalone Discourse Docker container template

# You may add rate limiting by uncommenting the web.ratelimited template.
# Out of the box it allows 12 reqs a second per ip, and 100 per minute per ip
# This is configurable by amending the params in this file

templates:
  - "templates/postgres.template.yml"
  - "templates/redis.template.yml"
  - "templates/web.template.yml"
  - "templates/sshd.template.yml"
  - "templates/web.ratelimited.template.yml"

## which TCP/IP ports should this container expose?
expose:
  - "80:80" # fwd host port 80 to container port 80 (http)
  - "2222:22" # fwd host port 2222 to container port 22 (ssh)

params:
  db_default_text_search_config: "pg_catalog.english"
  ## Set db_shared_buffers to 1/3 of the memory you wish to allocate to postgres
  ## on 1GB install set to 128MB on a 4GB instance you may raise to 1GB
  db_shared_buffers: "128MB"
  #
  ## Which Git revision should this container use? (default: tests-passed)
  #version: tests-passed

env:
  LANG: en_US.UTF-8
  # DISCOURSE_DEFAULT_LOCALE: en
 ## TODO: How many concurrent web requests are supported?
  ## With 2GB we recommend 3-4 workers, with 1GB only 2
  UNICORN_WORKERS: 2

  ## TODO: List of comma delimited emails that will be made admin and developer
  ## on initial signup example 'user1@example.com,user2@example.com'
  DISCOURSE_DEVELOPER_EMAILS: 'jatwood@codinghorror.com,elizabeth@webcomresources.com'

  ## TODO: The domain name this Discourse instance will respond to
  DISCOURSE_HOSTNAME: 'discuss.atchisonkansas.com'

  ## TODO: The mailserver this Discourse instance will use
  DISCOURSE_SMTP_ADDRESS: smtp.mandrillapp.com
  #DISCOURSE_SMTP_PORT: 587 # (optional)
  DISCOURSE_SMTP_USER_NAME: elizabeth@webcomresources.com
  DISCOURSE_SMTP_PASSWORD: 

  ## The CDN address for this Discourse instance (configured to pull)
  #DISCOURSE_CDN_URL: //discourse-cdn.example.com

## These containers are stateless, all data is stored in /shared
volumes:
  - volume:
      host: /var/discourse/shared/standalone
      guest: /shared
  - volume:
      host: /var/discourse/shared/standalone/log/var-log
      guest: /var/log

## The docker manager plugin allows you to one-click upgrade Discourse
## http://discourse.example.com/admin/docker
hooks:
  after_code:
    - exec:
       cd: $home/plugins
        cmd:
          - mkdir -p plugins
          - git clone https://github.com/discourse/docker_manager.git

## Remember, this is YAML syntax - you can only have one block with a name
run:
  - exec: echo "Beginning of custom commands"

  ## If you want to configure password login for root, uncomment and change:
  #- exec: apt-get -y install whois # for mkpasswd
  ## Use only one of the following lines:
  #- exec: /usr/sbin/usermod -p 'PASSWORD_HASH' root
  #- exec: /usr/sbin/usermod -p "$(mkpasswd -m sha-256 'RAW_PASSWORD')" root

  ## If you want to authorized additional users, uncomment and change:
  #- exec: ssh-import-id username
  #- exec: ssh-import-id anotherusername

  - exec: echo "End of custom commands"
  - exec: awk -F\# '{print $1;}' ~/.ssh/authorized_keys | awk 'BEGIN { print "Authorized SSH keys for this container:"; } NF>=2 {print $NF;}'

```

---

<div class="post-metadata">

### Author: ![johnmuhl](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/johnmuhl/32/43413_2.png) [@johnmuhl](https://meta.discourse.org/u/johnmuhl)
#### Post date: [May 2, 2015, 12:56am UTC](https://meta.discourse.org/t/bootstrap-failed-after-rebuild-changed-domain-name/28206/5 "2015-05-02T00:56:18Z")

</div>

[http://www.yamllint.com/](http://www.yamllint.com/) indicates you have a whitespace issue at the line (73) starting with `cmd:`. Looks like there is only 1 space of indentation where you need two spaces.

---

<div class="post-metadata">

### Author: ![wcr](https://avatars.discourse-cdn.com/v4/letter/w/77aa72/32.png) [@wcr](https://meta.discourse.org/u/wcr)
#### Post date: [May 2, 2015, 1:11am UTC](https://meta.discourse.org/t/bootstrap-failed-after-rebuild-changed-domain-name/28206/6 "2015-05-02T01:11:22Z")

</div>

That was faulty copying on my part. I double checked, it doesn’t have extra whitespace.

```
## After making changes to this file, you MUST rebuild for any changes
## to take effect in your live Discourse instance:
##
## /var/discourse/launcher rebuild app
##
## Make sure to obey YAML syntax! You can use this site to help check:
## http://www.yamllint.com/

## this is the all-in-one, standalone Discourse Docker container template

# You may add rate limiting by uncommenting the web.ratelimited template.
# Out of the box it allows 12 reqs a second per ip, and 100 per minute per ip
# This is configurable by amending the params in this file

templates:
  - "templates/postgres.template.yml"
  - "templates/redis.template.yml"
  - "templates/web.template.yml"
  - "templates/sshd.template.yml"
  - "templates/web.ratelimited.template.yml"

## which TCP/IP ports should this container expose?
expose:
  - "80:80" # fwd host port 80 to container port 80 (http)
  - "2222:22" # fwd host port 2222 to container port 22 (ssh)

params:
  db_default_text_search_config: "pg_catalog.english"
  ## Set db_shared_buffers to 1/3 of the memory you wish to allocate to postgres
  ## on 1GB install set to 128MB on a 4GB instance you may raise to 1GB
  db_shared_buffers: "128MB"
  #
  ## Which Git revision should this container use? (default: tests-passed)
  #version: tests-passed

env:
  LANG: en_US.UTF-8
  # DISCOURSE_DEFAULT_LOCALE: en
 ## TODO: How many concurrent web requests are supported?
  ## With 2GB we recommend 3-4 workers, with 1GB only 2
  UNICORN_WORKERS: 2

  ## TODO: List of comma delimited emails that will be made admin and developer
  ## on initial signup example 'user1@example.com,user2@example.com'
  DISCOURSE_DEVELOPER_EMAILS: 'jatwood@codinghorror.com,elizabeth@webcomresources.com'

  ## TODO: The domain name this Discourse instance will respond to
  DISCOURSE_HOSTNAME: 'discuss.atchisonkansas.com'

  ## TODO: The mailserver this Discourse instance will use
  DISCOURSE_SMTP_ADDRESS: smtp.mandrillapp.com
  #DISCOURSE_SMTP_PORT: 587 # (optional)
  DISCOURSE_SMTP_USER_NAME: elizabeth@webcomresources.com
  DISCOURSE_SMTP_PASSWORD: 3d5OzSmHtN_JtMPnRDDFEQ

  ## The CDN address for this Discourse instance (configured to pull)
  #DISCOURSE_CDN_URL: //discourse-cdn.example.com

## These containers are stateless, all data is stored in /shared
volumes:
  - volume:
      host: /var/discourse/shared/standalone
      guest: /shared
  - volume:
      host: /var/discourse/shared/standalone/log/var-log
      guest: /var/log

## The docker manager plugin allows you to one-click upgrade Discourse
## http://discourse.example.com/admin/docker
hooks:
  after_code:
    - exec:
       cd: $home/plugins
       cmd:
          - mkdir -p plugins
          - git clone https://github.com/discourse/docker_manager.git

## Remember, this is YAML syntax - you can only have one block with a name
run:
  - exec: echo "Beginning of custom commands"

  ## If you want to configure password login for root, uncomment and change:
  #- exec: apt-get -y install whois # for mkpasswd
  ## Use only one of the following lines:
  #- exec: /usr/sbin/usermod -p 'PASSWORD_HASH' root
  #- exec: /usr/sbin/usermod -p "$(mkpasswd -m sha-256 'RAW_PASSWORD')" root

  ## If you want to authorized additional users, uncomment and change:
  #- exec: ssh-import-id username
  #- exec: ssh-import-id anotherusername

  - exec: echo "End of custom commands"
  - exec: awk -F\# '{print $1;}' ~/.ssh/authorized_keys | awk 'BEGIN { print "Authorized SSH keys for this container:"; } NF>=2 {print $NF;}'

```

---

<div class="post-metadata">

### Author: ![pl3bs](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pl3bs/32/37266_2.png) [@pl3bs](https://meta.discourse.org/u/pl3bs)
#### Post date: [May 2, 2015, 1:15am UTC](https://meta.discourse.org/t/bootstrap-failed-after-rebuild-changed-domain-name/28206/7 "2015-05-02T01:15:45Z")

</div>

does it have the developer emails on that next line? that should remain on the same line.

---

<div class="post-metadata">

### Author: ![wcr](https://avatars.discourse-cdn.com/v4/letter/w/77aa72/32.png) [@wcr](https://meta.discourse.org/u/wcr)
#### Post date: [May 2, 2015, 1:18am UTC](https://meta.discourse.org/t/bootstrap-failed-after-rebuild-changed-domain-name/28206/8 "2015-05-02T01:18:40Z")

</div>

nope, they are all in one line. Just the way the code pasted into the post.

---

<div class="post-metadata">

### Author: ![pl3bs](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pl3bs/32/37266_2.png) [@pl3bs](https://meta.discourse.org/u/pl3bs)
#### Post date: [May 2, 2015, 1:24am UTC](https://meta.discourse.org/t/bootstrap-failed-after-rebuild-changed-domain-name/28206/9 "2015-05-02T01:24:57Z")

</div>

the error lies elsewhere, I just launched from your yaml config

---

<div class="post-metadata">

### Author: ![wcr](https://avatars.discourse-cdn.com/v4/letter/w/77aa72/32.png) [@wcr](https://meta.discourse.org/u/wcr)
#### Post date: [May 2, 2015, 1:53am UTC](https://meta.discourse.org/t/bootstrap-failed-after-rebuild-changed-domain-name/28206/10 "2015-05-02T01:53:41Z")

</div>

Thank you to @pl3bs!!! I had an error in the first line, he fixed it and I am up and running again!

---

<div class="post-metadata">

### Author: ![zogstrip](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/zogstrip/32/512781_2.png) [@zogstrip](https://meta.discourse.org/u/zogstrip)
#### Post date: [May 3, 2015, 5:24pm UTC](https://meta.discourse.org/t/bootstrap-failed-after-rebuild-changed-domain-name/28206/11 "2015-05-03T17:24:40Z")

</div>


