Bootstrap fails because of the wrong IP Address

(Seferi) #1

Hi, i just installed ubuntu server on my old laptop to try and experiment before i invest in a serious server. This is what i’m getting after answering the smtp questions:

Checking your domain name . . .

WARNING:: does not appear to resolve to

LET’S ENCRYPT cannot work if their servers cannot access your host by name.
Unless you think you know why this naive check failed, DO NOT USE Let’s Encrypt.
(A typical reason for failure is an AWS server with an elastic IP.)

You should probably answer “n” at the next prompt and disable Let’s Encrypt.

The IP adress is not the public IP but the one router is giving me. I appreciate if you could help. Thanks.

(cpradio) #2

It is a warning, you are welcome to ignore it if you feel you have port forwarding setup properly so that HTTPS can work utilizing Lets Encrypt, otherwise, say ‘n’ so it doesn’t use HTTPS.

(Seferi) #3

Thanks for the reply mate, i tried saying both yes and no, either way installation fails… my domain name is suppose to resolve to the public IP address of the discourse server right?

(cpradio) #4

actual logs so we know why would be beneficial versus assuming it is Lets Encrypt

(Jay Pfaffman) #5

If you answer no to let’s encrypt,and the install fails, it’s for some other reason. Perhaps rubygems rate limiting. Do a search to find that thread, I can’t deal on my tablet.

(cpradio) #6

The associated topic is