# Bootstrap 在 CentOS 7 上失败

**URL:** https://meta.discourse.org/t/bootstrap-fails-on-centos-7/48927
**Category:** Self-hosting
**Created:** [2016年八月20日 21:06 UTC](https://meta.discourse.org/t/bootstrap-fails-on-centos-7/48927 "2016-08-20T21:06:15Z")
**Posts on this page:** 7
**Page:** 2

<div class="post-metadata">

### Author: ![Edgar\_Martinez](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/edgar_martinez/32/68703_2.png) [@Edgar\_Martinez](https://meta.discourse.org/u/Edgar_Martinez)
#### Post date: [2017年三月8日 23:18 UTC](https://meta.discourse.org/t/bootstrap-fails-on-centos-7/48927/21 "2017-03-08T23:18:06Z")

</div>

Hi Krami i have a centos 7 and i change storage from **devicemapper** to **overlay** and when i launch the rebuild It send me error and is because I have ftype=0

```
[cevmf@server discourse]$ xfs_info /usr/lib/systemd/system/docker.service | grep ftype
naming =version 2 bsize=4096 ascii-ci=0 ftype=0

```

I try to change like you said with:

`sudo mkfs.xfs -n ftype=1 /usr/lib/systemd/system/docker.service`

but without luck, can you please help me what i´m doing wrong.

---

<div class="post-metadata">

### Author: ![kraml](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/kraml/32/68627_2.png) [@kraml](https://meta.discourse.org/u/kraml)
#### Post date: [2017年三月9日 02:41 UTC](https://meta.discourse.org/t/bootstrap-fails-on-centos-7/48927/22 "2017-03-09T02:41:18Z")

</div>

That’s not how you use mkfs.xfs … Yo need to have some basic understanding of filesystem vs. files.

mkfs.xfs creates a new filesystem(means wipes existing one if there already is) on a partition, it is not meant to be used on a file.

Here is RHEL storage administration guide. You have to at least understand partition and xfs.

[https://access.redhat.com/documentation/en-US/Red\_Hat\_Enterprise\_Linux/7/html/Storage\_Administration\_Guide/index.html](https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Storage_Administration_Guide/index.html)

You may need to spend sometime on it before you start to play with your precious data.

---

<div class="post-metadata">

### Author: ![Edgar\_Martinez](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/edgar_martinez/32/68703_2.png) [@Edgar\_Martinez](https://meta.discourse.org/u/Edgar_Martinez)
#### Post date: [2017年四月28日 16:56 UTC](https://meta.discourse.org/t/bootstrap-fails-on-centos-7/48927/23 "2017-04-28T16:56:48Z")

</div>

Hi Kraml in the solution 1, suppousing that I have the partition ext4 I just have to do a new installation of docker there?, and uninstalling the other version of docker? without move nothing in /var/discourse correct?

---

<div class="post-metadata">

### Author: ![kraml](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/kraml/32/68627_2.png) [@kraml](https://meta.discourse.org/u/kraml)
#### Post date: [2017年四月29日 05:59 UTC](https://meta.discourse.org/t/bootstrap-fails-on-centos-7/48927/24 "2017-04-29T05:59:18Z")

</div>

You need to mount the new partition under `/var/lib/docker`. If your don’t have containers other than discourse, you can stop docker, rename `/var/lib/docker` directory(for backup purpose), create a new one, mount the new partition under it, and start docker again. Then you need to bootstrap discourse and get back the container. Your discourse data is not under `/var/lib/docker` so they won’t lose.

---

<div class="post-metadata">

### Author: ![Julian\_Somoza](https://avatars.discourse-cdn.com/v4/letter/j/da6949/32.png) [@Julian\_Somoza](https://meta.discourse.org/u/Julian_Somoza)
#### Post date: [2017年十月14日 13:56 UTC](https://meta.discourse.org/t/bootstrap-fails-on-centos-7/48927/25 "2017-10-14T13:56:35Z")

</div>

To use overlay the new partition must be EXT4 or XFS with the flag ftype enabled… EXT4 is the recomended option.

---

<div class="post-metadata">

### Author: ![leoluk](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/leoluk/32/81742_2.png) [@leoluk](https://meta.discourse.org/u/leoluk)
#### Post date: [2017年十一月5日 20:08 UTC](https://meta.discourse.org/t/bootstrap-fails-on-centos-7/48927/26 "2017-11-05T20:08:34Z")

</div>

The issue described in this thread (permission denied) is due to SELinux, not `ftype=0`.

See [Support official Docker packages on Red Hat/CentOS](https://meta.discourse.org/t/support-official-docker-packages-on-red-hat-centos/73476)

---

<div class="post-metadata">

### Author: ![JammyDodger](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jammydodger/32/254611_2.png) [@JammyDodger](https://meta.discourse.org/u/JammyDodger)
#### Post date: [2024年六月8日 12:43 UTC](https://meta.discourse.org/t/bootstrap-fails-on-centos-7/48927/27 "2024-06-08T12:43:57Z")

</div>

此主题已在 2848 天后自动关闭。不再允许回复。

[上一頁](https://meta.discourse.org/t/bootstrap-fails-on-centos-7/48927.md?page=1)
