Bootstrap problems after moving to different server


#1

Here is the background:

I typically upgrade Discourse installs once per year during downtime for my site over the December holidays. I have had version 1.6.10 since last January. Recently I was forced to move servers on DigitalOcean. I went the long route by moving a snapshot of the entire install where I ran into various problems. I then started a new install with the intention to restore from a backup.

While trying to rebuild version 1.6.10 with my old app.yml I run into the following problem:

Here is the link to the json gem versions. Is there a solution to override this Make sure that gem install json -v '1.8.3' succeeds before bundling issue without having to upgrade Discourse versions?

I am dutifully equipped with snapshots and backups if someone has a different idea to help get my install back up and running.


(Dimitris Kritsotakis) #2

Hey! I recently transferred my Discourse instance to another server.
All I did was do a fresh install of the discourse to the new server, upload the backup, restore it and all the files/settings/posts/categories were exactly the same.


#3

I appreciate the response but my install is not as easy as that. I am currently bootstrapped in v1.8.0 on a development server and having all sorts of painful issues. I cannot load my restore on v1.9.0 without errors. I would prefer to be back on 1.6.10 until I have more time to address the extremely rapid upgrades.

It comes down to that json gem incompatibility. I need a different workaround.


#4

On an exact snapshot of my original server prior to moving (not the same fresh server as the first post), I get the following error while trying to bootstrap.

If I remedy the above I think I can get back up. Still in need of help.


(Jay Pfaffman) #5

I too would recommend a new install and restoring the backup. Something like this:

cd /var
mv discourse discourse.old
git clone https://github.com/discourse/discourse_docker.git /var/discourse
cp discourse.old/containers/app.yml discourse/containers
cd discourse
./launcher rebuild app
# visit site in web browser. Do a backup to see that backup directory exists
cp ../discourse.old/standalone/backup/default/THEMOSTRECENTBACKUP standalone/backup/default

Then, back in the web browser, enable restore site setting and restore the backup.


#6

Again I appreciate the response. I did do that earlier today and uploaded my most recent backup. The backup then fails. It does work in 1.8 but my plugins don’t load. I know what you’re going to say – remove plugins.

The point is I need to return to 1.6.10 so my users can have their site back. Meanwhile I will roll out necessary changes to make an upgrade all the way to 1.9.

I need to get to 1.6.10 as a temporary solution.


(Jay Pfaffman) #7

From what you’ve said, that’s going to be much more difficult than disabling a few plugins. I’m afraid that the only way to get help with problems with 1.6 will be travel back to last January.