# Bootstrapping fails - trying to install postgress in /shared?

**URL:** https://meta.discourse.org/t/bootstrapping-fails-trying-to-install-postgress-in-shared/26848
**Category:** Self-hosting
**Tags:** docker
**Created:** [March 26, 2015, 9:37pm UTC](https://meta.discourse.org/t/bootstrapping-fails-trying-to-install-postgress-in-shared/26848 "2015-03-26T21:37:20Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![RubyRhod](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/rubyrhod/32/40260_2.png) [@RubyRhod](https://meta.discourse.org/u/RubyRhod)
#### Post date: [March 26, 2015, 9:37pm UTC](https://meta.discourse.org/t/bootstrapping-fails-trying-to-install-postgress-in-shared/26848/1 "2015-03-26T21:37:21Z")

</div>

Hi, I’ve successfully got docker up and running on a Centos 7 VM, and am following the instructions at [https://github.com/discourse/discourse/blob/master/docs/INSTALL-digital-ocean.md](https://github.com/discourse/discourse/blob/master/docs/INSTALL-digital-ocean.md)

The server is a clean install, minimal install with updates applied via yum.

Everything seems to work fine until I get to the bootstrap section, then this piece of ugliness shows up:

```plaintext
[root@docker01 discourse]# ./launcher bootstrap app
which: no docker.io in (/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/root/bin)
cd /pups && git pull && /pups/bin/pups --stdin
From https://github.com/SamSaffron/pups
   ee8fdfb..4203610 master -> origin/master
Updating ee8fdfb..4203610
Fast-forward
 README.md | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)
I, [2015-03-26T21:26:26.486602 #42] INFO -- : Loading --stdin
I, [2015-03-26T21:26:26.492471 #42] INFO -- : > mkdir -p /shared/postgres_run
mkdir: cannot create directory ‘/shared/postgres_run’: Permission denied
I, [2015-03-26T21:26:26.495027 #42] INFO -- : 

FAILED
--------------------
RuntimeError: mkdir -p /shared/postgres_run failed with return #<Process::Status: pid 44 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:105:in `spawn'
exec failed with the params "mkdir -p /shared/postgres_run"
845f898dd251763eee8390ab439a8a3d8ccafb5678561309e0000f0dc2219401
FAILED TO BOOTSTRAP
```

From what I’m reading, it seems to be attempting to install postgres in /shared - I’m new to docker so I _assume_ it’s trying to install in that subdirectory of the docker jail. Sorry for using old-guy terminology - been running servers for years but never played with docker before.

Help greatfully received!

Thanks  
Dex

---

<div class="post-metadata">

### Author: ![RubyRhod](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/rubyrhod/32/40260_2.png) [@RubyRhod](https://meta.discourse.org/u/RubyRhod)
#### Post date: [March 26, 2015, 9:58pm UTC](https://meta.discourse.org/t/bootstrapping-fails-trying-to-install-postgress-in-shared/26848/2 "2015-03-26T21:58:35Z")

</div>

ok… not sure which fixed it, but I both a) rebooted, and b) made the shared/postgres directory

Now it’s bootstrapping, and seems to be ok.

Strange. Will update if any more problems, but I think I’m over the hump.

Cheers

---

<div class="post-metadata">

### Author: ![sam](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sam/32/102149_2.png) [@sam](https://meta.discourse.org/u/sam)
#### Post date: [March 26, 2015, 11:27pm UTC](https://meta.discourse.org/t/bootstrapping-fails-trying-to-install-postgress-in-shared/26848/3 "2015-03-26T23:27:43Z")

</div>


