Broken avatar images

unsupported-install

(Lokesh Sharma) #1

I have deployed Discourse on a docker in Cent OS along with other applications. After trying all I can I am still not able to fix the broken avatar images that I am getting. Please visit here to have a look. Here is my app.yml file. I know support for non default port is not there in Discourse but I still ask for your help as I have no other option.


(Joshua Rosenfeld) #2

@lokeshh, I can’t help with the avatar issue, but I want to point out that you posted your Gmail password in the attached app.yml. I highly recommend you change your gmail password, as well as any other services you use that have the same or similar password.


(Rafael dos Santos Silva) #3

This server is running apache on port 80, you can’t create another VirtualHost for Discourse on the same apache, and proxy from 80 to 8080?


(Lokesh Sharma) #4

I am accessing through port 8080 i.e. glug.nith.ac.in:8080. Not Apache involved here.


(Lokesh Sharma) #5

Thanks for pointing that out.


(Lokesh Sharma) #6

If you look at image source you will find this http://glug.nith.ac.in:8080/user_avatar/glug.nith.ac.in:8080/system/120/1_1.png

Of course this is not a valid url but how did it came about and what should be the correct one? Any idea?


(Jay Pfaffman) #7

Usually not if the host is managed by something like cpanel.

Please note, @lokeshh, Discourse absolutely will not work on a non-standard port.


(Lokesh Sharma) #8

I have worked hard to make it work. All that remains to do now is to make images work fine. I think this can be accomplished.

I just realized that I need to change

http://glug.nith.ac.in:8080/user_avatar/glug.nith.ac.in:8080/system/120/1_1.png

to

http://glug.nith.ac.in:8080/user_avatar/glug.nith.ac.in/system/120/1_1.png

Only the port needs to be removed while rendering the images in the link.

Any idea how this thing can be accomplished?


(Jeff Atwood) #9

Non standard HTTP/HTTPS ports are not supported in Discourse. You will need to proxy if it has to be on a different port.


(Lokesh Sharma) #10

Proxy it how? I tried to proxy ‘/forum’ to port 8080 using the following in httpd.conf but it didn’t worked. I just get a white screen:

ProxyPass “/forum” "http://localhost:8080"
ProxyPassReverse “/forum” “http://localhost:8080

See glug.nith.ac.in/forum

I managed to fix the broken avatars by manually editing the app running in the docker. This isn’t a good idea of course and I am looking for a more robust now. But it works for now. Yay!