Broken Discourse


(Johnny) #1

Hi,

I recently was able to successfully install and view discourse on nginx proxy. But now discourse seems broken, e.g

Page Not Found
while trying to load /categories.json

I have attached the image, any help?

EDIT: I already tried “rebuilding” and “boostrapping” the app like tens of times. but same result.


(Rafael dos Santos Silva) #2

Do you really need a nginx proxy with Discourse? That’s an advanced setup. We really recomend sticking to the quick guide and running everything inside the container and using a DNS subdomain for the forums.


(Johnny) #3

Yes, I have multiple domains, each with different configuration, hence I don’t want discourse to run on its own nginx. But via proxy through external nginx.


(Vinoth Kannan) #4

Could you share your nginx configuration to know more? Are you using multiple discourse containers in same VM?


(Matt Palmer) #5

Something is misconfigured. Without knowing exactly what your configuration is, it’s a bit hard to be more specific than that.


(Johnny) #6

Hi the issue was revolved. Site works fine. @Falco thanks for suggesting subdomain. However, as I am using proxy. I followed digital ocean’s example, now when I try to register an account, it then for registration proceeds to port “25654”, (https://meta.domain.com:25654/…" which gives error. as this port won’t respond.

port 25654 isn’t forwarding to port 80 :confused:

digital ocean’s example:

my Nginx config file is below.

http://pastebin.com/dMQvyvRS

my app.yml:

http://pastebin.com/751jp5Zh


(Johnny) #7

Hi,

I got it working. everything is working fine now except images. Images are broken. I tried all the dir’s such as “$domain/public/images/discourse.png” | “$domain/images/discourse.png” …

but it says not found. Discourse is unable to find the image. Even if i give absolute path in the admin settings i.e “/var/www/discourse/images/discourse.png” it still gives 404 error.

P.S: I am using SSL.