Broken links, possibly related to HTTPS


(Erlend Sogge Heggen) #1

I’m having trouble clicking the “my post above” link in @codinghorror’s post below. I’m on HTTPS. Is anyone else getting sent to the following url and blank page?

https://meta.discourse.org/clicks/track?url=http%3A%2F%2Fmeta.discourse.org%2Ft%2Fhow-to-arrive-at-a-conclusion%2F1178%2F14&post_id=36436&topic_id=1178

Continuing the discussion from How to arrive at a conclusion?:


(Bill Ayakatubby) #2

I see the same problem on HTTPS and HTTP.


(Michael Brown) #3

This is a side effect of our switch to HTTPS-only mode that we are addressing. Carry on! :smile:


(Erlend Sogge Heggen) #4

lol I just noticed. There was some weird remains from a previously saved draft I think.

@supermathie gotcha! Proceeding with carrying on.


(Sam Saffron) #5

Be sure to hard refresh your browser (shift-refresh) … otherwise some weird can happen


(Bill Ayakatubby) #6

It’s a click tracker problem. Hard refreshing doesn’t fix anything. The tracker gives a 21-byte response and then stops.


(Sam Saffron) #7

Click tracker seems to be working fine, I’m in the middle of rebaking meta, this should clean up some more of the strange.


(Bill Ayakatubby) #8

How long should re-baking take? I’m still seeing the problem @erlend_sh describes above, and in a different browser/OS.


(Sam Saffron) #9

Last I checked it had 20k jobs to go.


(Jeff Atwood) #10

Is it one job per post? That seems extreme. How about one job per topic?


(Jeff Atwood) #12

This topic was automatically closed after 3 hours. New replies are no longer allowed.


(Sam Saffron) #13

(Sam Saffron) #14

I am not following at all I tried and tried but can not find this broken link,

Pretty please a screen shot with a circle and arrow so I can see what is broke

cc @erlend_sh


(Bill Ayakatubby) #15

Taken with a phone, so pardon the amateurish shakycam. The screen flash around 0:09/0:10 is where I did a hard refresh with my keyboard.


(Sam Saffron) #16

Ok, rebake does not fix this. The issue is that the URL was something like:

http://meta.discourse.org/t/broken-links-possibly-related-to-https/11831 now our redirect in haproxy actually works, so if you navigate to it direct its all good.

However when clicked from here you see a blank page.

Will read through the link tracker to see if there is a way to make it more resilient


(Bill Ayakatubby) #17

A couple more problems that I’m seeing with the click tracker:

  • It looks like the same-origin logic isn’t working - it thinks http://meta.d is different from https://meta.d and opens internal links in a new window. (I have my user pref set to open external links in a new window.)
  • If I right-click on a link, then press Esc to close the context menu, then left-click the link, I get the link opened in a new window as well as the original window navigating to the link.

(Robin Ward) #18

Okay I’ve fixed the https :point_right: http links on the server side and in the Javascript click tracking as @BhaelOchon pointed out.

Let me know if you find anything else broken.


(Jeff Atwood) #19