Cached plan must not change result type


(Marco) #1

Just upgraded to 1.1.0.beta4
I don’t know exacty what’s changed but I love the user interface, it’s more polished. More space between topics?

Then I saw in the logs the following error:

PG::Error: ERROR:  cached plan must not change result type
: SELECT  "users".* FROM "users"  WHERE "users"."id" = $1 LIMIT 1

Should I worry?


(Neil Lalonde) #2

I haven’t seen this on any of our sites. Googling shows that the solution is to restart the app. So try launcher restart app?


(Sam Saffron) #3

This can happen during the time your run /admin/upgrade if we amend schema. Should go away as soon as deploy is done.


(Dean Taylor) #4

I can confirm @sam’s statement.

This error occurred for me during / very soon after a recent update; Google bot was making requests at the same time the upgrade was occurring.

It hasn’t occurred since.