Caching issues in Firefox with multiple privacy plugins active?

Hi,

This is from a user of my site, not sure anyone can duplicate:

I keep encountering a bug. After a few minutes of browsing I can no longer load the forum and get a page saying “Cannot load app - It looks like you are offline! Please check your network connection and try again.”

I can reload the website after I empty my cache (and then it recurs a few minutes later of browsing). It’s occurring with the latest version Firefox for the past few days. Not sure what’s the cause…

Any plugins installed?

yup, but nothing too exotic:

      - git clone https://github.com/discourse/docker_manager.git
      - git clone https://github.com/discourse/discourse-spoiler-alert.git
      - git clone https://github.com/botoggle/discord-onebox.git
      - git clone https://github.com/botoggle/always-mobile-timeline.git
      - git clone https://github.com/botoggle/nicovideo-onebox.git

Sorry I meant any Firefox plugins?

Are you able to repro here (we are running latest)?

I haven’t been able to reproduce the issue myself yet, just bumped to latest for the first time in about six weeks yesterday so we’ll see if it recurs.

Hi, I’m the user who is having the issue. Active firefox plugins are HTTPS everywhere, privacy badger, and ublock origins.

1 Like

Can you reproduce in Firefox safe mode? If you cannot, it is one of the plugins.

2 Likes

Looks like it’s an issue with one of the plugins – issue didn’t recur in safe mode.

3 Likes

OK, thanks for the quick responses all. FWIW I don’t think it’s necessary to run Privacy Badger on top of UBO.

1 Like

Hiccup found out Privacy Badger seems to be the reason for « Cannot load app. »

4 Likes