Call to action not displaying


(David Kingham) #1

I have the cta turned on in settings but when I browse as an anon user the cta never displays even after browsing to many different pages. I am using SSO with memberful, does the cta turn off when using SSO?


(Jeff Atwood) #2

Most likely; SSO means “magic login via parent site”, so logins aren’t really handled by Discourse any more.


(David Kingham) #3

Thanks Jeff, I do think the CTA does work with SSO based upon this post.

I was trying to change the link in the CTA when I realized it was never showing up to start with. What are the triggers for the CTA? I’ve tried going to as many pages as possible and it never displays.


(Jeff Atwood) #4

You should be able to trigger it here as an anon user. Just read a few topics and be scrolled to the bottom of a topic.

(Not sure if it triggers on try.discourse.org it might there as well)


(David Kingham) #5

Yes I tried it logged out and was able to trigger it here, still cannot get it to trigger on my site.


(Kane York) #6

All the data it uses is in localStorage. You can check it from the dev console:

>> [localStorage["discourse_anon-topic-ids"], localStorage["discourse_anon-topic-time"]]


(David Kingham) #7

I looked in the console and do not see anything related to localStorage, but I’m pretty ignorant on this so I may be looking at something wrong.

You mentioned this:

Does using s3 disable localStorage?


(Kane York) #8

Sorry for not being more specific, see that arrow > at the bottom? That’s a prompt, you can type there. Put in the code I posted.


(David Kingham) #9

This is all I get