# Can not activation mail to smtp.yandex.ru mail server

**URL:** https://meta.discourse.org/t/can-not-activation-mail-to-smtp-yandex-ru-mail-server/157020
**Category:** Self-hosting
**Created:** [7 ביולי,‏ 2020,‏ 11:01am UTC](https://meta.discourse.org/t/can-not-activation-mail-to-smtp-yandex-ru-mail-server/157020 "2020-07-07T11:01:32Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![kudos](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/kudos/32/186280_2.png) [@kudos](https://meta.discourse.org/u/kudos)
#### Post date: [7 ביולי,‏ 2020,‏ 11:01am UTC](https://meta.discourse.org/t/can-not-activation-mail-to-smtp-yandex-ru-mail-server/157020/1 "2020-07-07T11:01:32Z")

</div>

I’m trying to install Discourse Docker on an AWS server. After the build process completed, I must register an account for admin.

 ![image](https://global.discourse-cdn.com/meta/original/3X/d/3/d32b7e5a35182c9a8b29109366e08141127d7804.png)

Then, I click to the Register button but it doesn’t send any email for me.  
I used the `./discourse-doctor` tool for checking some problem, but I get this:

```plaintext
==================== MAIL TEST ====================
For a robust test, get an address from mail-tester .com
Or just send a test message to yourself.
Email address for mail test? ('n' to skip) [info@deephub.vn]:
Sending mail to info@deephub.vn. . .
Testing sending to info@deephub.vn using smtp .yandex .ru:465.
================== ERROR =======================
                                    UNEXPECTED ERROR

Net::ReadTimeout

================ SOLUTION ==============
This is not a common error. No recommended solution exists!

Please report the exact error message above to meta .discourse .org
(And a solution, if you find one!)
==========================================
Replacing: SMTP_PASSWORD
Replacing: LETSENCRYPT_ACCOUNT_EMAIL
Replacing: DEVELOPER_EMAILS
Replacing: DISCOURSE_DB_PASSWORD
Replacing: Sending mail to

==================== DONE! ====================

```

I configured for SPF and DKIM records in my DNS.

Telnet is OK  
`telnet smtp.yandex.ru 465`

Any ideas on how I can fix this?

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [8 ביולי,‏ 2020,‏ 11:54am UTC](https://meta.discourse.org/t/can-not-activation-mail-to-smtp-yandex-ru-mail-server/157020/2 "2020-07-08T11:54:11Z")

</div>

You can try connecting from inside the container. It’s possible that you have some docker networking issue.

---

<div class="post-metadata">

### Author: ![kudos](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/kudos/32/186280_2.png) [@kudos](https://meta.discourse.org/u/kudos)
#### Post date: [10 ביולי,‏ 2020,‏ 6:13am UTC](https://meta.discourse.org/t/can-not-activation-mail-to-smtp-yandex-ru-mail-server/157020/3 "2020-07-10T06:13:22Z")

</div>

Thanks, @pfaffman. I tried telnetting from inside the container. And it’s OK.
