Can not configure my Bitnami Discourse instance to send out mails

unsupported-install

(Abiodun Olumide Daniels) #1

I recently finished installation of my Discourse app using Bitnami on AWS and since then, it’s not been sending out mails for confirming user emails, even mine as Admin has not been confirmed. Please point me in the right direction to fix this issue.

-Abbey


(Jay Pfaffman) #2

You can ask Bitnami or you can install the supported way: discourse/INSTALL-cloud.md at master · discourse/discourse · GitHub. You’ll need to use something to deliver the mail, see discourse/INSTALL-email.md at master · discourse/discourse · GitHub.


(Abiodun Olumide Daniels) #3

Thank you for the prompt response. Think I got what I was looking for. :+1:


(Dave) #4

If you have the ability to edit the zone files for that domain you can use the Amazon SES service to forward the email for your forums domain. As long as you stay under the caps it’s included with your account and/or under your free tier. Until you contact Amazon and ask for the limits to be lifted there is default throttling port 25 on all instances. You don’t necessarily need to use SES but you do need to let AWS know you want to send mail.

https://aws.amazon.com/ses/


(Jay Pfaffman) #5

Services like Mailgun receive SMTP on port 2525 for this reason.


(Dave) #6

That’s a good way to overcome that limitation. I don’t see where you’d get into trouble with the AWS AUP using it the way Discourse intends to inform users, etc by using the other Mailgun ports. It doesn’t say no mail relays, it just says no spamming. I think for most unless you’ve already got a hookup or investment in AWS you’d be better off getting a Droplet at DO and using one of the SMTP relays from the install docs.


(Abiodun Olumide Daniels) #7

Thank you for your suggestion. Tried working on it but couldn’t get it to work. Already sent a support ticket AWS


(Dave) #8

I had a similar issue but I’m using the bootstrapped container pulled from the Discourse repo and not the Bitnami image.

When you connect to SES it needs to be via a verified email/domain as the return address known to SES when you applied for SES. Discourse needs to be set to use that address as the sender to be able to connect to SES.

At the bottom of the app.yml file there is a line that needs to be uncommented with the SES log in address as the parameter for SiteSetting.notification_email . When I did that and rebuilt the app I was able to send mail.

As the others say the Bitnami instances it could be different but for the stock install it’s what I had to do.