Can only post in Uncategorised since upgrading from beta6 to beta10


(Sam Stickland) #1

Hi,

I’ve just upgraded and now all the users (including admins) can only post in the uncategorised category. I can view all the topics, but in the ‘New Topic’ form the Category box only shows ‘Uncategorised’

Any idea what might be wrong?

S


(Sam Stickland) #2

Topic creation via email and topic replies are working.


(Sam Stickland) #3

OK, more strangeness.

If I go in and reset the permissions on one category then I can post to that category again. But as soon as I repeat this for the next category (staff) the list of categories in the new form resets back to just Uncategorised.

EDIT: Actually it’s losing the category I just reset the permissions for as soon as I navigate to a different part of the site.

EDIT: Nothing new in the error logs.


(Jeff Atwood) #4

Are you on the absolute latest version? If not, get on it. /admin/update


(Sam Stickland) #5

Yup. I’m on “v1.4.0.beta10 +226”


(Sam Saffron) #6

Any plugins running?


(Sam Stickland) #7

Nope, no plugins runnings.

I increased the size of the external avatar URL field, and I have a custom polyfill that rewritten Email::Receiver.process with some additional logic to handle incoming posts from a conjoined mailing-list (which is still working fine)


(Sam Saffron) #8

Any JavaScript errors, have you tried a diff browser?


(Sam Stickland) #9

I don’t see any Javascript errors in Chrome, although it did record this 404:

GET http://forums.hubbado.com/assets/select2.png 404 (Not Found)

I’ve just tried it in MS Edge and I have the same problem there, and a colleague has reported the same problem in Safari on a Mac.


(Sam Saffron) #10

Can you try a rebuild?


(Sam Stickland) #11

OK, I’ve just been through a rebuild (/var/discourse/launcher rebuild app) and I’ve still got the same problems.