# Can’t send emails due to failed internal dns resolution

**URL:** https://meta.discourse.org/t/can-t-send-emails-due-to-failed-internal-dns-resolution/43592
**Category:** Support
**Created:** [2016 年 5 月 3 日午前 8:45 UTC](https://meta.discourse.org/t/can-t-send-emails-due-to-failed-internal-dns-resolution/43592 "2016-05-03T08:45:48Z")
**Posts on this page:** 1
**Showing post:** 14

<div class="post-metadata">

### Author: ![Kevin\_McKinney](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/kevin_mckinney/32/54497_2.png) [@Kevin\_McKinney](https://meta.discourse.org/u/Kevin_McKinney)
#### Post date: [2016 年 5 月 4 日午後 4:02 UTC](https://meta.discourse.org/t/can-t-send-emails-due-to-failed-internal-dns-resolution/43592/14 "2016-05-04T16:02:38Z")

</div>

> [@gvalchca](#):
>
> I’ve changed the DOCKER\_OPTS:DOCKER\_OPTS=“–ip 127.0.0.1”

The second time I installed Discourse, I was having issues where emails wouldn’t send (same setup as you - internal SMTP at my company). It turned out that I had to [configure Docker to find our DNS server](https://meta.discourse.org/t/initial-email-failure-job-exception-getaddrinfo-name-or-service-not-known/42301/4) because it couldn’t resolve the SMTP server.

I added this to the bottom of my DOCKER\_OPTS:  
`DOCKER_OPTS="--dns 172.X.X.X --dns 172.X.X.X"`

---

_[View the full topic](https://meta.discourse.org/t/can-t-send-emails-due-to-failed-internal-dns-resolution/43592)._
