# "canned acl" error when uploading images

**URL:** https://meta.discourse.org/t/canned-acl-error-when-uploading-images/205293
**Category:** Support
**Created:** [October 5, 2021, 8:55pm UTC](https://meta.discourse.org/t/canned-acl-error-when-uploading-images/205293 "2021-10-05T20:55:02Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![Vortico](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/vortico/32/149922_2.png) [@Vortico](https://meta.discourse.org/u/Vortico)
#### Post date: [October 5, 2021, 8:55pm UTC](https://meta.discourse.org/t/canned-acl-error-when-uploading-images/205293/1 "2021-10-05T20:55:02Z")

</div>

When I try to upload an image to a post in my forum, it fails to upload the image and I get an error message

> Unsupported value for canned acl ‘public-read’

 ![2021-10-05T16:45:27-04:00](https://global.discourse-cdn.com/meta/original/3X/0/e/0e50bdfbf0543dd9e6df903bae344f5719702664.png)

This looks like an S3 error, but I have “enable s3 uploads” disabled in the file settings. I don’t want to upload images to S3. I have `DISCOURSE_USE_S3` set to `true` in `app.yml`, but this is for daily S3 backups.

Does anyone see anything wrong with my configuration? Thanks!

 ![2021-10-05T16:50:27-04:00](https://global.discourse-cdn.com/meta/original/3X/9/a/9a2aff604cbd96c8de55806cce86679cb930f618.png)

---

<div class="post-metadata">

### Author: ![RGJ](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/rgj/32/523185_2.png) [@RGJ](https://meta.discourse.org/u/RGJ)
#### Post date: [October 5, 2021, 9:04pm UTC](https://meta.discourse.org/t/canned-acl-error-when-uploading-images/205293/2 "2021-10-05T21:04:11Z")

</div>

> [@Vortico](#):
>
> I have `DISCOURSE_USE_S3` set to `true` in `app.yml` , but this is for daily S3 backups

But it’s not. `DISCOURSE_USE_S3` is for uploads.

---

<div class="post-metadata">

### Author: ![Vortico](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/vortico/32/149922_2.png) [@Vortico](https://meta.discourse.org/u/Vortico)
#### Post date: [October 5, 2021, 9:08pm UTC](https://meta.discourse.org/t/canned-acl-error-when-uploading-images/205293/3 "2021-10-05T21:08:40Z")

</div>

I set it to `false` and rebuilt the container, but it didn’t seem to fix the error or upload failure. I re-enabled it, but I’ll try it again.

---

<div class="post-metadata">

### Author: ![Vortico](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/vortico/32/149922_2.png) [@Vortico](https://meta.discourse.org/u/Vortico)
#### Post date: [October 5, 2021, 9:19pm UTC](https://meta.discourse.org/t/canned-acl-error-when-uploading-images/205293/4 "2021-10-05T21:19:13Z")

</div>

`DISCOURSE_USE_S3` is now false, and the container is rebuild, but it’s still showing the original error message.

I noticed this message appears in my admin dashboard.

> The server is configured to upload files to S3, but there is no S3 CDN configured. This can lead to expensive S3 costs and slower site performance. [See “Using Object Storage for Uploads” to learn more](https://meta.discourse.org/t/-/148916).

But I don’t want to upload files to S3. How do I disable it? Both `DISCOURSE_USE_S3` and “enable s3 uploads” are disabled.

---

<div class="post-metadata">

### Author: ![Simsnet](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/simsnet/32/72855_2.png) [@Simsnet](https://meta.discourse.org/u/Simsnet)
#### Post date: [October 5, 2021, 9:36pm UTC](https://meta.discourse.org/t/canned-acl-error-when-uploading-images/205293/5 "2021-10-05T21:36:02Z")

</div>

Did you comment out the line in `app.yml`?

---

<div class="post-metadata">

### Author: ![Vortico](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/vortico/32/149922_2.png) [@Vortico](https://meta.discourse.org/u/Vortico)
#### Post date: [October 5, 2021, 9:37pm UTC](https://meta.discourse.org/t/canned-acl-error-when-uploading-images/205293/6 "2021-10-05T21:37:56Z")

</div>

No, I set it to `false`. I’ll try commenting it out.

---

<div class="post-metadata">

### Author: ![Vortico](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/vortico/32/149922_2.png) [@Vortico](https://meta.discourse.org/u/Vortico)
#### Post date: [October 5, 2021, 10:12pm UTC](https://meta.discourse.org/t/canned-acl-error-when-uploading-images/205293/7 "2021-10-05T22:12:51Z")

</div>

I’ve commented out `DISCOURSE_USE_S3` and all `DISCOURSE_S3_*` settings, and I can now upload images. However, I believe this will break the daily backups to S3. I suppose I can try commenting out _just_ `DISCOURSE_USE_S3`, waiting 24 hours, and checking whether both uploads without S3 and backups with S3 still work.

---

<div class="post-metadata">

### Author: ![Vortico](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/vortico/32/149922_2.png) [@Vortico](https://meta.discourse.org/u/Vortico)
#### Post date: [October 5, 2021, 10:28pm UTC](https://meta.discourse.org/t/canned-acl-error-when-uploading-images/205293/8 "2021-10-05T22:28:55Z")

</div>

Looks like I must omit all `DISCOURSE_S3_*` settings to make uploads work. Is there a way to allow both S3 backups and _non_-S3 uploads to work in Discourse?

Here are my relevant `app.yml` variables for reference. Currently everything is commented out.

```plaintext
  # DISCOURSE_USE_S3: false
  # DISCOURSE_S3_REGION: "us-west-000"
  # DISCOURSE_S3_INSTALL_CORS_RULE: false
  # DISCOURSE_S3_CONFIGURE_TOMBSTONE_POLICY: false
  # DISCOURSE_S3_ENDPOINT: https://s3.us-west-000.backblazeb2.com
  # DISCOURSE_S3_ACCESS_KEY_ID: <censored>
  # DISCOURSE_S3_SECRET_ACCESS_KEY: <censored>
  # DISCOURSE_S3_BUCKET: community-backup
  # DISCOURSE_S3_BACKUP_BUCKET: community-backup
  # DISCOURSE_BACKUP_LOCATION: s3

```
