Cannot add user to private message by autocomplete


(Theron Boerner) #1

If you use the autocomplete, it grays out the invite button. If you type in the full username, it works fine.


(Jeff Atwood) #2

Can you provide the exact sequence of keys and mouse to repro because I cannot repro. As soon as I type 1 or 2 chars the button enables.


(Theron Boerner) #3

Video of it: WATDISCOURSEWAT

It looks like hitting tab or enter to complete it does not work but clicking on the name does.


(Jeff Atwood) #4

Ok good repro @neil can you add this to your list for Canada tuesday?


(Sander Datema) #5

I like the idea that - even in this digital age - some software development is bound to certain locations. Canada is a very populair location for squashing bugs for example.


(Neil Lalonde) #6

This hackerino in autocomplete.js is to blame for the disabled invite button. I spent too long trying to solve it, but failed. Git blame has @sam’s name all over it so maybe he can figure it out.

In the case when user-selector has allowAny=true, and you select a username from the autocomplete list, that _.delay will set the input’s value to a blank string 50 ms after it was set to the selected username.


(Jeff Atwood) #7

@techapj can we still repro this?


(Arpit Jalan) #8

Nope, clicking ENTER or TAB to autocomplete works just fine now.


(Arpit Jalan) #9