# Cannot get past bootstrapping

**URL:** <https://meta.discourse.org/t/cannot-get-past-bootstrapping/364284>\
**Category:** Self-hosting\
**Created:** [April 30, 2025, 7:27pm UTC](https://meta.discourse.org/t/cannot-get-past-bootstrapping/364284 "2025-04-30T19:27:43Z")\
**Posts on this page:** 1\
**Showing post:** 8

<div class="post-metadata">

**Author:** ![tknospdr](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/tknospdr/32/529762_2.png) [@tknospdr](https://meta.discourse.org/u/tknospdr)\
**Post date:** [April 30, 2025, 11:42pm UTC](https://meta.discourse.org/t/cannot-get-past-bootstrapping/364284/8 "2025-04-30T23:42:01Z")

</div>

Here’s the errors I found in the install output, none look like show stoppers:

```plaintext
690:M 30 Apr 2025 22:05:22.859 # Warning: Could not create server TCP listening socket *:6379: bind: Address already in use
690:M 30 Apr 2025 22:05:22.859 # Failed listening on port 6379 (TCP), aborting.

```

```plaintext
109:M 30 Apr 2025 21:59:42.411 # WARNING Memory overcommit must be enabled! Without it, a background save or replication may fail under low memory condition...

```

```plaintext
2025-04-30 21:59:41.125 UTC [60] postgres@postgres ERROR: database "discourse" already exists
2025-04-30 21:59:41.274 UTC [63] postgres@discourse ERROR: role "discourse" already exists

```

```plaintext
WARN: Unresolved or ambiguous specs during Gem::Specification.reset:
      stringio (>= 0)
      Available/installed versions of this gem:
      - 3.1.7
      - 3.1.5
      - 3.1.1
WARN: Clearing out unresolved specs. Try 'gem cleanup <gem>'
Please report a bug if this causes problems.

```

```plaintext
The setting 'staticAddonTrees' will default to true in the next version of Embroider and can't be turned off. To prepare for this you should set 'staticAddonTrees: true' in your Embroider config.
The setting 'staticAddonTestSupportTrees' will default to true in the next version of Embroider and can't be turned off. To prepare for this you should set 'staticAddonTestSupportTrees: true' in your Embroider config.

```

```plaintext
Node.js heap_size_limit is less than 2048MB. Setting --max-old-space-size=2048 and CHEAP_SOURCE_MAPS=1

```

```plaintext
-e DISCOURSE_SMTP_DOMAIN=discourse.example.com

```

```plaintext
[BABEL] Note: The code generator has deoptimised the styling of /var/www/discourse/app/assets/javascripts/discourse/ember/ember-template-compiler.js as it exceeds the max of 500KB.
[BABEL] Note: The code generator has deoptimised the styling of /var/www/discourse/app/assets/javascripts/discourse/ember/ember.js as it exceeds the max of 500KB.

```

---

_[View the full topic](https://meta.discourse.org/t/cannot-get-past-bootstrapping/364284)._
