# Cannot install v1.8.1 (newer version works)

**URL:** <https://meta.discourse.org/t/cannot-install-v1-8-1-newer-version-works/64798>\
**Category:** Self-hosting\
**Created:** [2017年六月20日 09:58 UTC](https://meta.discourse.org/t/cannot-install-v1-8-1-newer-version-works/64798 "2017-06-20T09:58:12Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![joostdj](https://avatars.discourse-cdn.com/v4/letter/j/57b2e6/32.png) [@joostdj](https://meta.discourse.org/u/joostdj)\
**Post date:** [2017年六月20日 09:58 UTC](https://meta.discourse.org/t/cannot-install-v1-8-1-newer-version-works/64798/1 "2017-06-20T09:58:12Z")

</div>

I want to install Discourse v1.8.1 using discourse\_docker, as this is the current stable release. However, the “launcher rebuild” script fails. I’m using the standalone configuration. The strange thing is that the latest tag (v1.9.0.beta2) works without errors. The last part of the build log looks like this:

```
== Seed from /var/www/discourse/plugins/discourse-narrative-bot/db/fixtures/001_discobot.rb
 - User {:id=>-2, :name=>"discobot", :username=>"discobot", :username_lower=>"discobot", :email=>"discobot_email", :password=>"55211674fd4a01e1dee61545b8173fb4", :active=>true, :approved=>true, :trust_level=>4}

I, [2017-06-20T09:48:16.509139 #14] INFO -- : Terminating async processes
I, [2017-06-20T09:48:16.509216 #14] INFO -- : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/postgresql/9.5/bin/postmaster -D /etc/postgresql/9.5/main pid: 84
I, [2017-06-20T09:48:16.509290 #14] INFO -- : Sending TERM to exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf pid: 197
2017-06-20 09:48:16.513 UTC [84] LOG: received fast shutdown request
2017-06-20 09:48:16.513 UTC [84] LOG: aborting any active transactions
2017-06-20 09:48:16.513 UTC [91] LOG: autovacuum launcher shutting down
197:signal-handler (1497952096) Received SIGTERM scheduling shutdown...
2017-06-20 09:48:16.521 UTC [88] LOG: shutting down
197:M 20 Jun 09:48:16.543 # User requested shutdown...
197:M 20 Jun 09:48:16.543 * Saving the final RDB snapshot before exiting.
197:M 20 Jun 09:48:16.549 * DB saved on disk
197:M 20 Jun 09:48:16.550 # Redis is now ready to exit, bye bye...
2017-06-20 09:48:17.435 UTC [88] LOG: database system is shut down

FAILED
--------------------
Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate' failed with return #<Process::Status: pid 2008 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:108:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"bundle_exec", "cmd"=>["su discourse -c 'bundle install --deployment --verbose --without test --without development'", "su discourse -c 'bundle exec rake db:migrate'", "su discourse -c 'bundle exec rake assets:precompile'"]}
002b1b1a968e2a0893f4d0aa1691df313d7ffd7b6a72c42918e68d4a56636c32
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one

```

This might cause the issue:

```
> Seeding dark and light themes
rake aborted!
IPAddr::InvalidAddressError: invalid address
/var/www/discourse/vendor/bundle/ruby/2.4.0/gems/seed-fu-2.3.5/lib/seed-fu/runner.rb:46:in `eval'
/var/www/discourse/lib/freedom_patches/open_uri_redirections.rb:70:in `open_uri'
/var/www/discourse/lib/file_helper.rb:31:in `block in download'
/var/www/discourse/lib/file_helper.rb:30:in `open'
/var/www/discourse/lib/file_helper.rb:30:in `download'
/var/www/discourse/app/models/user_avatar.rb:71:in `import_url_for_user'
(eval):21:in `block (2 levels) in run_file'
/var/www/discourse/vendor/bundle/ruby/2.4.0/gems/seed-fu-2.3.5/lib/seed-fu/runner.rb:46:in `eval'
/var/www/discourse/vendor/bundle/ruby/2.4.0/gems/seed-fu-2.3.5/lib/seed-fu/runner.rb:46:in `block (2 levels) in run_file'
/var/www/discourse/vendor/bundle/ruby/2.4.0/gems/seed-fu-2.3.5/lib/seed-fu/runner.rb:58:in `block in open'
/var/www/discourse/vendor/bundle/ruby/2.4.0/gems/seed-fu-2.3.5/lib/seed-fu/runner.rb:57:in `open'
/var/www/discourse/vendor/bundle/ruby/2.4.0/gems/seed-fu-2.3.5/lib/seed-fu/runner.rb:57:in `open'
/var/www/discourse/vendor/bundle/ruby/2.4.0/gems/seed-fu-2.3.5/lib/seed-fu/runner.rb:36:in `block in run_file'
/var/www/discourse/vendor/bundle/ruby/2.4.0/gems/activerecord-4.2.8/lib/active_record/connection_adapters/abstract/database_statements.rb:213:in `block in transaction'
/var/www/discourse/vendor/bundle/ruby/2.4.0/gems/activerecord-4.2.8/lib/active_record/connection_adapters/abstract/transaction.rb:184:in `within_new_transaction'
/var/www/discourse/vendor/bundle/ruby/2.4.0/gems/activerecord-4.2.8/lib/active_record/connection_adapters/abstract/database_statements.rb:213:in `transaction'
/var/www/discourse/vendor/bundle/ruby/2.4.0/gems/activerecord-4.2.8/lib/active_record/transactions.rb:220:in `transaction'
/var/www/discourse/vendor/bundle/ruby/2.4.0/gems/seed-fu-2.3.5/lib/seed-fu/runner.rb:35:in `run_file'
/var/www/discourse/vendor/bundle/ruby/2.4.0/gems/seed-fu-2.3.5/lib/seed-fu/runner.rb:26:in `block in run'
/var/www/discourse/vendor/bundle/ruby/2.4.0/gems/seed-fu-2.3.5/lib/seed-fu/runner.rb:25:in `each'
/var/www/discourse/vendor/bundle/ruby/2.4.0/gems/seed-fu-2.3.5/lib/seed-fu/runner.rb:25:in `run'
/var/www/discourse/vendor/bundle/ruby/2.4.0/gems/seed-fu-2.3.5/lib/seed-fu.rb:29:in `seed'
/var/www/discourse/lib/tasks/db.rake:8:in `block in <top (required)>'
/var/www/discourse/vendor/bundle/ruby/2.4.0/gems/rake-11.3.0/exe/rake:27:in `<top (required)>'
/usr/local/bin/bundle:22:in `load'
/usr/local/bin/bundle:22:in `<main>'
Tasks: TOP => db:migrate
(See full trace by running task with --trace)

```

My server is behind a corporate proxy. It seems to have been fixed by this commit (for 1.9):

[https://github.com/discourse/discourse/commit/d8ba1c66d5274ea8c488d81e129ab234c0304966](https://github.com/discourse/discourse/commit/d8ba1c66d5274ea8c488d81e129ab234c0304966)

Any chance this could get merged into the current stable (1.8.x)?

---

<div class="post-metadata">

**Author:** ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)\
**Post date:** [2017年六月20日 23:30 UTC](https://meta.discourse.org/t/cannot-install-v1-8-1-newer-version-works/64798/2 "2017-06-20T23:30:43Z")

</div>

Sure @eviltrout can we backport that?

---

<div class="post-metadata">

**Author:** ![eviltrout](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/eviltrout/32/5275_2.png) [@eviltrout](https://meta.discourse.org/u/eviltrout)\
**Post date:** [2017年六月21日 17:04 UTC](https://meta.discourse.org/t/cannot-install-v1-8-1-newer-version-works/64798/3 "2017-06-21T17:04:50Z")

</div>

It was already backported to stable on June 13th.

@joostdj make sure you are using the latest commits from the stable branch.

---

<div class="post-metadata">

**Author:** ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)\
**Post date:** [2017年六月23日 01:00 UTC](https://meta.discourse.org/t/cannot-install-v1-8-1-newer-version-works/64798/4 "2017-06-23T01:00:28Z")

</div>

This topic was automatically closed after 30 hours. New replies are no longer allowed.
