"Cannot load app" for a meta topic

(Arnold Schrijver) #13

There have been responses to the Privacy Badger GH issue #1953 and the issue is reproducable in FF without PB:

@ghostwords commented on Github:

So I am not sure Privacy Badger is responsible for your problem (since I can reproduce without Privacy Badger) but something weird is going on here (Privacy Badger’s popup is in the wrong state sometimes).

(Jeff Atwood) #14

It says

that implies the problem may be on their end? Remember we are a javascript application, not a traditional 1996 plain vanilla HTML+CSS website, so the approach is rather different.

1 Like
(Arnold Schrijver) #15

Thanks @codinghorror! As I understand it part of the problem is on Discourse + Firefox end (triggering the error message page), but apart from that sometimes an empty PB menu appears, which is a the other end :slight_smile:

#16

I had the same problem for my site and also got it for this page here.

It has something to do with Privacy badger, but it can be difficult to reproduce.
For my site, it happened in the following situation:

  1. Privacy badger enabled, domain of my site was whitelisted explicitly under “Whitelisted domains”.
  2. When going to the site via a Google search result click.
  3. Force HTTPS enabled. (Not sure if this matters.)
  4. Firefox as browser

The problem didn’t occur when going to the site directly, only when going to it via Google Search result click. A refresh on the page didn’t work, unless the browser was restarted.
Also, HTTP request headers didn’t seem to matter (such as removing referrer).

The problem went away when I removed the whitelist of my site from Privacy Badger. But I also got it on this page here, not sure why exactly.

Seems like some kind of a strange bug in Privacy Badger.

1 Like
(Sam Saffron) #17

Do you mind posting this at?

2 Likes
(Rafael dos Santos Silva) split this topic #18

22 posts were split to a new topic: Discourse won’t load after rebuild

(Gerhard Schlager) #19

I’m seeing this message from time to time when I’m in a different network than the last time I used the Discourse app on my Android phone. Unfortunately I can’t reproduce it all the time and it always works on reload.

2 Likes
(Arnold Schrijver) #20

Currently I sometimes see a different error when pasting a meta discourse URL in an existing open tab on my Firefox browser (v60.0 now, on Ubuntu):


Corrupted Content Error

The site at https://meta.discourse.org/t/what-is-a-wiki-post-and-how-can-i-make-one/21622 has experienced a network protocol violation that cannot be repaired.

The page you are trying to view cannot be shown because an error in the data transmission was detected.


Opening a new tab and pasting the URL in there has no problem loading the page.

(Jeff Atwood) #21

I can’t repro this in Firefox 60.0 for Windows?

1 Like
(Arnold Schrijver) #22

I get the error on any existing, open tab where I paste, except if this tab already shows a Meta page, in which case the new URL is loading correctly. Very strange.

Edit: Solved… Found the issue! For some reason Privacy Badger had meta.discourse.org blocked. Note: this is not something I manually configured. I have reported to Privacy Badger using their built-in reporter, and added a link to this post.

This shows the PB settings (note that meta.discourse.org is no longer set to PB defaults):

Note also that on the pasted URL’s the Meta page loaded, but PB is not active. It shows the empty tracker dropdown

4 Likes
(Bhanu Sharma) #23

I can repro this under special circumstances!

It is a very edge case with my laptop that wifi doesn’t automatically gets connected upon resuming from sleep. What happens when i connect wifi is that discourse tries to reload and gives the same Corrupt Content Error and a refresh is enough (Just like it was in cannot load app) to get the site back.

(Cameron:D) #24

I am receiving the corrupted content error on Firefox 59 mobile any time FF is unloaded from memory. You can reliably reproduce it by opening a meta topic (or my own site topic), opening the app switcher and swiping FF closed, then opening FF again. Note that FF60 is currently rolling out so I’m not sure if that contains a fix for mobile.

I have received it in the past on desktop but am entirely unsure how to repro.

I’m also unsure if that leaves Firefox at fault, or the standard Discourse nginx config.

(Jeff Atwood) #25

Firefox 59 has some bugs in this area, so I suggest upgrading ASAP. 60 is the current version.

5 Likes
(Cameron:D) #26

Yep. Manually downloaded 60 on my phone and it seems to be fixed

4 Likes
(Arnold Schrijver) #27

The entire “Cannot load app” issue may be solved with FF 60.0! I added that comment to the Privacy Badger Github issue as well.

2 Likes
(Ben Bullard) #28

Hello everyone. I’m sort of a Linux monkey at openmandriva.org. :monkey:

And for my first post here I’ll be discussing a pet peeve.

I’m in FF 60 right now and am seeing this “Cannot load app” error for forum.openmandriva.org. It is probably because the web site is down for maintenance. But I hate the wording of this error message. It is not descriptive of what is happening.

I think that consideration needs to be given to writing the code in such a way that the error message reflects what is actually happening.

One day it’s “Cannot load app” when no app is involved. Next it will be the decline and fall of civilization as we know it! :skull_and_crossbones:

(Rafael dos Santos Silva) #29

This was fixed here:

2 Likes
(Ben Bullard) #30

Um, except I refreshed multiple times and the page did not change.

Again this is a situation where I already know the web site was down. My objection is that Discourse does not say that it tell users the inane “Cannot load app” when in fact the website was down for maintenance.

Edit: It may be that there is something wrong on the forum.openmandriva.org end. If so someone let me know and I will pass it on. Like is that message still there because of the version on Discourse OpenMandriva is using?

1 Like
(Jeff Atwood) #31

Looks up from here, perhaps try in Firefox Safe Mode to rule out oddball plugins or settings?

(Jeff Atwood) closed #32