Cannot Log in / Create New Account on Samsung Galaxy S3


#1

I tried with 3 different Samsung Galaxy S3s. (Android 4.3, which is latest for S3.)

Cannot Log in:

  • Unknown error occurrs.
    (Tried at some Discourse websites and here meta.discourse.org also.)

Cannot Create New Account:

  • It seems kind of clicking error? Login modal got away easily.
  • Can’t click some buttons & fields properly to proceed.
  • Can’t scroll properly.
  • But here on meta.discourse.org… I succeeded to create a new account ‘sometimes’. (but failed to log in)

I tried on iPhone 4S, Samsung Galaxy S3, Samsung Galaxy Note 2, LG Optimus G pro, and Google Nexus 7.

Only Galaxy S3 was the problem.


I tried again with Chrome mobile on Samsung Galaxy S3, it worked. I could log in.

But other browsers… default one and others… not working.

ps.

My country uses Chrome not that much. and there are many people using S3. I am worrying about this.

Is it not a bug? Then sorry. Maybe just Samsung’s fault…? :dizzy_face:


(Jeff Atwood) #2

Looks like some problem with the custom browser Samsung uses on that model? What’s the version number of it. I’ve heard of very ancient versions of WebKit being used.


#3

They said: Webkit 534.

http://mobilewebtest.eu/galaxys3

http://www.quirksmode.org/mobilebrowsers/

Is it the information you needed?


(Jeff Atwood) #4

Based on this, looks like WebKit version 534 is from about 2011-2012 or so? Very, very old.


#5

Yes, it is old. :older_man:

So… do you think it can be solved?


(Jeff Atwood) #6

Unfortunately no; they’ll need to either update Android or update to Chrome. Discourse only supports Android 4.1+. Galaxy S3 launched as an Android 4.0 device, so it’d need to be updated.


#7

But the Android 4.3 is currently installed on those Galaxy S3s.


(Jeff Atwood) #8

Yeah, I guess the issue is the default Samsung “browser” is based on an ancient 2012 version of WebKit. We only support Chrome as the default Android browser.


#9

I see. (I’d better ask this problem to Samsung guys in smartphone dept.)

Thank you for the answers anyway!